[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: kdenetwork-7:4.2.1-1.fc10.i386



"Stanisław T. Findeisen" wrote:
> What is this kdenetwork-7:4.2.1-1.fc10.i386 ? I guess it's the first 
> time I see an RPM package with ":" in its name.

The 7: means that the package has an epoch of 7.  For various reasons,
a package might need to be updated to a version that rpm would
consider older, based on rpm's evaluation of the version and release.
When this occurs, epoch is used.  So foo-2.0-1 with an epoch of 0
would be seen as older than foo-1.0-1 with an epoch of 1.

> More amazing is, however, that it both exists and does not exist on
> my system at the same time.
>
> $ rpm --erase --test libgadu-1.8.2-1.fc10.i386
> error: Failed dependencies:
>         libgadu.so.3 is needed by (installed) kdenetwork-7:4.2.1-1.fc10.i386

This is simply an indication that you cannot remove libgadu because
kdenetwork depends on it.  Authur's suggestion to use yum for removing
packages is the best answer.

> $ rpm --erase --test kdenetwork-7:4.2.1-1.fc10.i386
> error: package kdenetwork-7:4.2.1-1.fc10.i386 is not installed

You would be better here to simply use "rpm --erase --test kdenetwork"
(though you'd still run into other complaints about packages that
required kdenetwork).

-- 
Todd        OpenPGP -> KeyID: 0xBEAF0CE3 | URL: www.pobox.com/~tmz/pgp
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Formerly we suffered from crimes; now we suffer from laws.
    -- Publius Cornelius Tacitus, Roman historian, AD 56 - c. 120

Attachment: pgpo4jnbutR8z.pgp
Description: PGP signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]