[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: dnsmasq configuration



On Thu, 2009-04-02 at 15:51 +1030, Tim wrote:
> On Thu, 2009-04-02 at 09:27 +1100, Simon Slater wrote:
> > After a reboot I got the message:
> >
> > dnsmasq failed to bind DHCP server socket: address already in use.
> 
> Which may be that something *else* is using it, or that dnsmasq is
> starting up in a way that causes problems with itself.  I've seen that
> sort of thing when there's a network with IPv4 and IPv6 addressing in
> use, and a service starts up.  It listens to both, and while starting up
> complains that the port's already in use while trying to listen to the
> second interface (which is really the first, with the IPv6 type of
> addresses, as well as IPv4).
> 
> > In the startup sequence as it scrolls on the screen, dnsmasq is near
> > the end, but is running:
> > [root dell ~]# service dnsmasq status
> > dnsmasq (pid 2613) is running...
> >
> >         So is the problem with the configuration or at startup?  How
> > do I find what is conflicting for the socket address?
> 
> man netstat
> 
> e.g. netstat -antuevp
Thanks Tim,

Now this shows that dnsmasq is using 192.168.122.1:53 with tcp and udp.
This is the link local address on a port for dns.  Also udp on
0.0.0.0:67 which is one of the dhcp ports but for all networks?

Does dnsmasq need to use 192.168.122.1?
The first aim is to get dhcp going.  Would 0.0.0.0:67 help or get in the
way?

-- 
Regards,
Simon Slater
Registered Linux User #463789. Be counted at: http://counter.li.org/


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]