[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: How to reassign "hibernate/restore/resume" partition on F9?



David wrote:
I probably just need to edit one character in a config file somewhere
.. but where ?
	
PROBLEM SUMMARY

Recently I upgraded the boot hard drive on this F9 box from 20GB to
250GB. In the process, I intentionally
reversed the swap and root partition numbers.

Old system: swap=sda6, root=sda5
New system: swapA=sda5, rootA=sda6

I've edited grub.conf and /etc/fstab in an attempt to accomodate this
change. However there is something I have missed, because
hibernate/restore fails and breaks swap (unless I workaround with a
"resume" kernel boot parameter).

PROBLEM SYMPTOMS

(1) Kernel boot message "Trying to resume from /dev/sda6".

This is wrong, it should be sda5.

Have you looked at your /etc/grub.conf file for resume= parameters to the kernels?

(2) The swap partition is correctly detected.

# cat /proc/swaps
Filename				Type		Size	Used	Priority
/dev/sda5                               partition	4200956	0	-1

(3) Hibernation (from gnome menu) fails to restore. A failed restore
leaves "cat /proc/swaps" blank even after reboot, requiring I recreate
swapA=sda5 with mkswap and swapon. Also I have experienced one
possibly related instance of rootA=sda6 filesystem corruption
requiring fsck repair with many errors corrected.

CURRENT WORKAROUND

If I add "resume=/dev/sda5" to my kernel boot command in grub.conf
then hibernation is ok.

kernel /vmlinuz-2.6.25-14.fc9.i686 resume=/dev/sda5 ro 5 root=LABEL=rootA

ADDITIONAL DETAILS

The old system was working fine with root=sda5 and swap=sda6. But I
changed this on the new drive because I have space for alternative
root partitions for experimentation. For an orderly layout I decided
to have the swap partition at sda5, followed by 4 alternative root
partitions. The first (sda6) labelled rootA, holds all files copied
(rescue mode, unmounted) from the old root partition. The old drive is
now removed from the system.

The new swap partition is 4301789184 bytes and is created with
# /sbin/mkswap -L swapA /dev/sda5

The relevant lines (without tab chars) in the new /etc/fstab are
LABEL=rootA / ext3 defaults 1 1
LABEL=swapA swap swap defaults 0 0

REQUEST FOR HELP

With the workaround I can make the symptoms go away, but I would like
to better understand the heart of the problem, because the resume
kernel parameter is not needed ordinarily. I imagine that initial F9
install created a configuration setting somewhere, that I need to
change. Obviously just changing fstab is not enough.

Not knowing enough about either kernel or pm-utils I am unsure where
to look for the origin of the kernel boot message. I did look at all
files listed by "rpm -ql pm-utils" but saw nothing that helped. Re
that I tried grep -r "Trying to resume" under /usr/lib/pm-utils
without success. And I had no luck on the net, due to too many
unrelated hits. So any assistance or kicks in the right direction will
be appreciated, thanks.

David



--
Kevin J. Cummings
kjchome rcn com
cummings kjchome homeip net
cummings kjc386 framingham ma us
Registered Linux User #1232 (http://counter.li.org)


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]