[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: F10 locked up while installing dl'd updates



On Sun, 2009-04-05 at 17:10 +0200, Nigel Henry wrote:
> First I must say that the F10 freezup, was not F10's fault, but a continuing 
> problem I have with my Asus M2N-X Plus mobo, as it happens with other 
> distros.
> 
> Back to the plot.
> 
> While the updates on F10 were installing, the machine decided to freeze. No 
> keyboard, no mouse, no nothing, except a static image on KDE, like a 
> screenshot. I had no alternative, but to press the reboot button.
> 
> When I've had this happen on Debian installs, I run apt-get dist-upgrade, and 
> apt-get complains, telling me to run, dpkg-reconfigure -a. This fixes the 
> problem with packages that were partially installed when the machine froze 
> up, then running apt-get dist-upgrade again, the remaining packages are 
> installed.
> 
> When F10 rebooted, I ran apt-get dist-upgrade (I use apt on Fedora), but 
> apt-get complained about dependency problems due to duplicate packages on the 
> system.
> 
> Apt-get gave the following errors.
> E:  Transaction set check failed
> E:  Handler silently failed
> 
> I tried various suggestions from apt-get, like, apt-get --fix-broken install, 
> with no success.
> 
> After a serious session of rpm -e on the various packages that had duplicates, 
> some 3hrs later, I had reduced the list of problem packages to zero, and ran 
> apt-get dist-upgrade again, which now continued with installing the remaining 
> packages.
> 
> The question is, is there some command I could have used on Fedora, similar to 
> the Debian, dpkg-reconfigure -a, which is able to resolve problems with 
> partially installed packages, when you get a power out, or in my case, the 
> machine decides to freeze up, while installing the updates.
> 
> I had a good look in the man page for rpm, but couldn't see anything there 
> that might help, but there may be other commands not in the man page of 
> course.
> 
> As usual, thanks for any suggestions.
----
yum install yum-tools

package-cleanup --help

Craig


-- 
This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]