[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: F10 locked up while installing dl'd updates



On Sunday 05 April 2009 17:15, Craig White wrote:
> On Sun, 2009-04-05 at 17:10 +0200, Nigel Henry wrote:
> > First I must say that the F10 freezup, was not F10's fault, but a
> > continuing problem I have with my Asus M2N-X Plus mobo, as it happens
> > with other distros.
> >
> > Back to the plot.
> >
> > While the updates on F10 were installing, the machine decided to freeze.
> > No keyboard, no mouse, no nothing, except a static image on KDE, like a
> > screenshot. I had no alternative, but to press the reboot button.
> >
> > When I've had this happen on Debian installs, I run apt-get dist-upgrade,
> > and apt-get complains, telling me to run, dpkg-reconfigure -a. This fixes
> > the problem with packages that were partially installed when the machine
> > froze up, then running apt-get dist-upgrade again, the remaining packages
> > are installed.
> >
> > When F10 rebooted, I ran apt-get dist-upgrade (I use apt on Fedora), but
> > apt-get complained about dependency problems due to duplicate packages on
> > the system.
> >
> > Apt-get gave the following errors.
> > E:  Transaction set check failed
> > E:  Handler silently failed
> >
> > I tried various suggestions from apt-get, like, apt-get --fix-broken
> > install, with no success.
> >
> > After a serious session of rpm -e on the various packages that had
> > duplicates, some 3hrs later, I had reduced the list of problem packages
> > to zero, and ran apt-get dist-upgrade again, which now continued with
> > installing the remaining packages.
> >
> > The question is, is there some command I could have used on Fedora,
> > similar to the Debian, dpkg-reconfigure -a, which is able to resolve
> > problems with partially installed packages, when you get a power out, or
> > in my case, the machine decides to freeze up, while installing the
> > updates.
> >
> > I had a good look in the man page for rpm, but couldn't see anything
> > there that might help, but there may be other commands not in the man
> > page of course.
> >
> > As usual, thanks for any suggestions.
>
> ----
> yum install yum-tools
>
> package-cleanup --help
>
> Craig

Hi Craig.

As you see from the above, I'm using apt on Fedora. That said though, I will 
install the package you suggest.

Now I'm on dialup, and the problem I had where the machine froze up, was after 
downloading over 540MB of packages using apt-get. Last time I updated was 
20090315, and the latest, where I had the problem 20090404.

The difference between apt, and yum, is where they put the downloaded 
packages. Apt puts them in /var/cache/apt/archives. Packages from all the 
repos are placed here. Yum splits the repos up, and puts the packages for the 
different repos in separate directories. So for example the yum updates are 
in /var/cache/yum/updates/packages.

I've tried the GUI way of moving the packages from apt to yum, but means 
renaming yum directories temporarily, so as to be able to copy and paste 
from /var/cache/apt/archives to /var/cache/yum/updates/packages (packages 
temporarily renamed to archives)

There has to be an easier way than that on the CLI. 

How do I copy the files in /var/cache/apt/archives 
to /var/cache/yum/updates/packages?

Nigel.

Sorry, this has been a pain in the backside for the last 2 days.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]