[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: sudo and privoxy



Beartooth wrote:
My wife's machine is on a different floor. Nine times out of ten, when she hollers for help, it's a browser that won't connect; and nine out of ten of those times, it's because privoxy has somehow gotten stopped. (The other times, I usually have to reboot the router a/o the modem.)

I tried adding her to the privoxy group, using Fedora's "Users and Groups" app. But I still get :
[btth Hbsk2 ~]$ su - tslg
Password: [tslg Hbsk2 ~]$ service privoxy restart
Can't find /usr/sbin/privoxy, exit.

Is there a reason you're becoming tslg and trying to restart privoxy?
You should be root to restart privoxy, so as user btth:

	$ su -
	(enter root password)
	# service privoxy restart
	# exit
	$

should do it.  Ideally, you should use "sudo service privoxy restart",
but your username has to be in /etc/sudoers (see below).

[tslg Hbsk2 ~]$ sudo service privoxy restart
[sudo] password for tslg: tslg is not in the sudoers file. This incident will be reported. [tslg Hbsk2 ~]$
	What am I doing wrong??

Whatever user is trying to invoke sudo MUST be in the /etc/sudoers file.
There's another reply to this thread that describes how to put that in
(by using visudo).
----------------------------------------------------------------------
- Rick Stevens, Systems Engineer                      ricks nerd com -
- AIM/Skype: therps2        ICQ: 22643734            Yahoo: origrps2 -
-                                                                    -
-      We are born naked, wet and hungry. Then things get worse.     -
----------------------------------------------------------------------


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]