[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Compiling problem



Jim writes:

Thank you that solved the compile problem, but when i tried to execute "inq" i get this error message;

$ inq
inq: error while loading shared libraries: libinklevel.so.5: cannot open shared object file: No such file or directory

The libinklevel.so.5 file is at

/usr/local/lib/libinklevel.so.5
/usr/local/lib/libinklevel.so.5.0.0

/usr/local/lib is not in the default runtime loader search path.

This application has a slightly broken makefile and/or configuration script. By default, it installs its libraries in a directory that is not searched by the loader, at runtime. Obviously broken.

There are several ways to solve this. The easiest way, the cop-out, is to fiddle with certain environment variables and/or configuration files in /etc. I'm not going to tell you how, because even though it's easier, it will lead to problems later down the line, and it's a broken solution.

The proper way, which requires more work, but is the right way to fix this, is to rebuild the application so its binaries get linked with the -R/usr/local/lib flag. If this application uses autoconf, this is done by passing an extra argument 'LDFLAGS=-R/usr/local/lib' to its configure script. If it uses a different configuration system, consult this application's help file for instructions on passing additional compiler options, for building.


Attachment: pgp8AKUu94wcU.pgp
Description: PGP signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]