[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: size from df -kh vs size from fdisk -l



jbyers:
> Error: File system has an incompatible feature enabled.
>
> does this last  tell us anything useful?
> perhaps better to just reformat sda1?
-------
 aldo foot:
That's informative. I would do one of two things:
 (a) reformat the partition and create a new filesystem,
 or
 (b) use GParted to grow the filesystem to the full extent of the partition.

Note that a partition can be 200GB, but there could be a small filesystem that
does not occupy the entire partition... such is your case.
--------
jbyers:

ok, i used gparted from a  systemrescuecd
it took me  a while to see how to grow the fs
but it  worked

GParted 0.4.1

Libparted 1.8.8
Check and repair file system (ext3) on /dev/sda1  00:00:31    ( SUCCESS )
        
calibrate /dev/sda1  00:00:00    ( SUCCESS )
        
path: /dev/sda1
start: 63
end: 42989939
size: 42989877 (20.50 GiB)
check file system on /dev/sda1 for errors and (if possible) fix them  00:00:00    ( SUCCESS )
        
e2fsck -f -y -v /dev/sda1
        
Pass 1: Checking inodes, blocks, and sizes
Pass 2: Checking directory structure
Pass 3: Checking directory connectivity
Pass 4: Checking reference counts
Pass 5: Checking group summary information

11 inodes used (0.02%)
0 non-contiguous inodes (0.0%)
# of inodes with ind/dind/tind blocks: 0/0/0
12003 blocks used (5.98%)
0 bad blocks
0 large files

0 regular files
2 directories
0 character device files
0 block device files
0 fifos
0 links
0 symbolic links (0 fast symbolic links)
0 sockets
--------
2 files
e2fsck 1.41.3 (12-Oct-2008)
grow file system to fill the partition  00:00:31    ( SUCCESS )
        
resize2fs /dev/sda1
        
Resizing the filesystem on /dev/sda1 to 21494936 (1k) blocks.
The filesystem on /dev/sda1 is now 21494936 blocks long.

resize2fs 1.41.3 (12-Oct-2008)


mount
...
/dev/sda1 on /mnt/sda1 type ext3 (rw)

root sysresccd /root % df -kh
Filesystem            Size  Used Avail Use% Mounted on
 ...
/dev/sda1              20G  7.0M   19G   1% /mnt/sda1

so, finally  the fs size looks same as partition

--------
one last comment
prior to doing the resize
# /sbin/blkid
 
urrrrrrrkkkk:
/dev/sda1: LABEL="/boot" UUID="e9ebdaea-2ae2-4a99-8eee-bf3ca8af7b8b" SEC_TYPE="ext2" TYPE="ext3"
used to be  LABEL="/"

further proof, if any was needed,
that the  f10liveinstallcd  tried to put in a /boot partition
overwriting my entire   fc5  /  partition

thanks to all who helped
Jack
 


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]