[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Remote administration of FC 10 headless servers.



On 22 Apr 2009 at 14:47, Steve Ellis wrote:

Date sent:      	Wed, 22 Apr 2009 14:47:16 -0700
From:           	Steve Ellis <ellis brouhaha com>
To:             	"Michael D. Setzer II" <mikes kuentos guam net>
Copies to:      	"Community assistance, encouragement, and advice for 
using Fedora." <fedora-list redhat com>
Subject:        	Re: Remote administration of FC 10 headless servers.

> Michael D. Setzer II wrote:
> > On 22 Apr 2009 at 13:52, Steve Ellis wrote:
> >
> >
> >   
> >> Like Tim and unlike Mark, I also have trouble with this--I believe this 
> >> is a selinux-enabled problem with respect to PackageKit/PolicyKit and 
> >> VNC sessions, at least based on the googling that I've been able to do.  
> >> I've tried changing policy from my actual console (which is 
> >> inconveniently 7 feet off the ground in the garage), but have thus far 
> >> been unable to have much luck--I haven't tried completely wide-open 
> >> policies though.  I did install yumex for finding installables, 
> >> however.   I use 'yum update' from the command line for regular updating.
> >>
> >> -se
> >>
> >>     
> >
> > You do have to open up the port in the firewall.
> > system-config-firewall 
> > other ports
> > Click Add
> > Enter port 5900 + port you use for server 
> > Example:
> > vncserver :50
> > Add port 5950 TCP
> >
> >
> >   
> Thanks for the suggestion, but firewall blocking vnc is not part of my 
> problem--I have no trouble vnc'ing into my system, I've already opened 
> the firewall appropriately.  In fact, I'm vnc'ed into my system over an 
> ssh tunnel from my office right now.  The problem I (and likely Tim) hit 
> manifests as a dialog box when running 
> "System->Administration->Add/Remove Software" that says:
> 
> "Package installer is running when the session is not active
> These applications should be run only when on active console.
> This normally indicates a bug with your remote desktop implementation."
> 
> However, I'm now thinking it may not have anything to do with selinux, 
> as I see that I switched to Permissive mode--I don't recall when I did 
> that, but I'm guessing it was before my vnc session was last restarted.  
> In my copious free time I'll climb back up on my step ladder and try to 
> tweak the settings in "System->Preferences->System->Authorizations" 
> further to see if I can get anywhere.

I see what you mean now. See the same error. I use yumex and it seems to 
work fine from vnc. 


> 
> -se


+----------------------------------------------------------+
  Michael D. Setzer II -  Computer Science Instructor      
  Guam Community College  Computer Center                  
  mailto:mikes kuentos guam net                            
  mailto:msetzerii gmail com
  http://www.guam.net/home/mikes
  Guam - Where America's Day Begins                        
+----------------------------------------------------------+

http://setiathome.berkeley.edu (Original)
Number of Seti Units Returned:  19,471
Processing time:  32 years, 290 days, 12 hours, 58 minutes
(Total Hours: 287,489)

BOINC HOME CREDITS
SETI 7,671,635.2685 | EINSTEIN 2,465,893.2309 | ROSETTA 
873,793.3373


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]