[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: F10 recent network problem



Dennis Mattingly wrote:
 >A few other things which might be relevant:
 >
 >Have you tried to disable the firewall and restart the network:
 >[as root]
 >$ service iptables stop
 >$ service network stop
 >$ service NetworkManager restart
 >
 >..if that doesn't help then post the output from
 >[as root]
 >$ route -n
 >$ ethtool eth0
 >$ ifconfig eth0
 >$ ping 127.0.0.1
 >$ chkconfig --list | grep [35]:on
 >..which may shed some light on what's going on.

Yes, refreshing the Firewall did help.
Now my eth0 (and NetworkManager) start successfully.

However, my route table is empty.
So still no internet with my router / DHCP.

SUMMARY


[root localhost ~]# service network stop
Shutting down interface eth0:                              [  OK  ]
Shutting down loopback interface:                          [  OK  ]

[root localhost ~]# service NetworkManager stop
Stopping NetworkManager daemon:                            [  OK  ]

OK, something is wrong here. You managed to successfully shut down both network and NetworkManager. It's not normal to have both of these active at the same time and bad things will happen if both of them are trying to manage the same interface (like overwriting your routing tables).

On my machines I tend to use the older 'network' system for fixed ethernet connections, and the newer NetworkManager for wireless connections. However NetworkManager should be able to manage fixed DHCP connections too and is probably the more generic way of handling network connections now.

To set up just the traditional 'network' system:

[as root]
service NetworkManger stop
chkconfig --del NetworkManager
service network restart
chkconfig --add network
ifdown eth0
ifup eth0

.. if you're still not able to route anywhere then run

system-config-network

select eth0 and press "Edit".

Check that "Controlled by NetworkManager"  is unticked.

Check that "Automatically obtain IP address setting with DHCP" is checked

Check that there are no hardcoded routes defined.

Reboot just to make sure everything is cleared.




If you want to use NetworkManager [I don't use this much so I'll leave it for others to correct me here!]

[as root]
service network stop
chkconfig --del network
service NetworkManger restart
chkconfig --add NetworkManager

..possibly reboot just to be sure everything's clear.


Hopefully one of those will get you up and running again.

TTFN

Simon.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]