[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: FC10 and NDISwrapper



On Mon, Apr 27, 2009 at 03:18:31PM +0100, Gary Stainburn wrote:
> I'm trying to get WIFI working on my new DELL and I've been told to try 
> ndiswrappers.

What does lspci say? Maybe you don't need ndiswrappers.

> I tried 
> 
> yum search ndiswrapper
> 
> and varients, but nothing was found. I then found RPMs using rpmsearch and 
> downloaded them.
> 
> Now when I try 'yum localinstall' it adds the kernel as a dependancy, 
> downloads it, and then errors saying it is already installed.
> 
> If I try 'rpm -i'  it fails on dependancy for /boot/vmlinuz
> 
> I've included the session log. Has anyone any suggestions?

Yes, it looks like you downloaded the packages for an i586 kernel,
which in reality you run an i686 one. Just download the same kmdl
package ending with i686.rpm (not i586.rpm), or simply use yum
pointing to ATrpms and do yum install ndiswrappers.

> Gary
> [root gary gary]# yum localinstall ~gary/ndiswrapper-1.54-20.fc10.i386.rpm 
> ndiswrapper-kmdl-2.6.27.21-170.2.56.fc10-1.54-20.fc10.i586.rpm 
> Loaded plugins: refresh-packagekit                                                                                                        
> Setting up Local Package Process                                                                                                          
> Examining /home/gary/ndiswrapper-1.54-20.fc10.i386.rpm: 
> ndiswrapper-1.54-20.fc10.i386                                                     
> Marking /home/gary/ndiswrapper-1.54-20.fc10.i386.rpm to be installed                                                                      
> fedora                                                                                                                                | 
> 2.8 kB     00:00     
> adobe-linux-i386                                                                                                                      |  
> 951 B     00:00     
> updates                                                                                                                               | 
> 2.3 kB     00:00     
> Examining ndiswrapper-kmdl-2.6.27.21-170.2.56.fc10-1.54-20.fc10.i586.rpm: 
> ndiswrapper-kmdl-2.6.27.21-170.2.56.fc10-1.54-20.fc10.i586                         
> Marking ndiswrapper-kmdl-2.6.27.21-170.2.56.fc10-1.54-20.fc10.i586.rpm to be 
> installed                                                                       
> Resolving Dependencies                                                                                                                                       
> --> Running transaction check                                                                                                                                
> ---> Package ndiswrapper.i386 0:1.54-20.fc10 set to be updated                                                                                               
> ---> Package ndiswrapper-kmdl-2.6.27.21-170.2.56.fc10.i586 0:1.54-20.fc10 set 
> to be updated                                                                  
> --> Processing Dependency: /boot/vmlinuz-2.6.27.21-170.2.56.fc10.i586 for 
> package: ndiswrapper-kmdl-2.6.27.21-170.2.56.fc10                                  
> Importing additional filelist information                                                                                                                    
> --> Running transaction check                                                                                                                                
> ---> Package kernel.i586 0:2.6.27.21-170.2.56.fc10 set to be installed                                                                                       
> --> Finished Dependency Resolution                                                                                                                           
> 
> Dependencies Resolved
> 
> =============================================================================================================================================================
>  Package                                      Arch     Version                      
> Repository                                                          Size 
> =============================================================================================================================================================
> Installing:                                                                                                                                                  
>  ndiswrapper                                  i386     
> 1.54-20.fc10                 /home/gary/ndiswrapper-1.54-20.fc10.i386.rpm                        
> 48 k 
>  ndiswrapper-kmdl-2.6.27.21-170.2.56.fc10     i586     1.54-20.fc10                 
> ndiswrapper-kmdl-2.6.27.21-170.2.56.fc10-1.54-20.fc10.i586.rpm     186 k 
> Installing for dependencies:                                                                                                                                 
>  kernel                                       i586     2.6.27.21-170.2.56.fc10      
> updates                                                             19 M 
> 
> Transaction Summary
> =============================================================================================================================================================
> Install      3 Package(s)                                                                                                                                    
> Update       0 Package(s)                                                                                                                                    
> Remove       0 Package(s)                                                                                                                                    
> 
> Total size: 19 M
> Total download size: 234 k
> Is this ok [y/N]: y
> Downloading Packages:
> Running rpm_check_debug
> Running Transaction Test
> Finished Transaction Test
> 
> 
> Transaction Check Error:
>   package kernel-2.6.27.21-170.2.56.fc10.i586 is already installed
> 
> Error Summary
> -------------
> 
> [root gary gary]# rpm -i ndiswrapper-1.54-20.fc10.i386.rpm 
> ndiswrapper-kmdl-2.6.27.21-170.2.56.fc10-1.54-20.fc10.i586.rpm
> warning: ndiswrapper-1.54-20.fc10.i386.rpm: Header V4 DSA signature: NOKEY, 
> key ID 66534c2b
> error: Failed dependencies:
>         /boot/vmlinuz-2.6.27.21-170.2.56.fc10.i586 is needed by 
> ndiswrapper-kmdl-2.6.27.21-170.2.56.fc10-1.54-20.fc10.i586
> [root gary gary]# uname -a
> Linux gary.ringways.co.uk 2.6.27.21-170.2.56.fc10.i686 #1 SMP Mon Mar 23 
> 23:37:54 EDT 2009 i686 i686 i386 GNU/Linux
> [root gary gary]#
> 

-- 
Axel.Thimm at ATrpms.net

Attachment: pgpbJObwgr9hi.pgp
Description: PGP signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]