[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: F11: Fedora Eclipse: SVN fails to connect to any svn repository: Hangs.



On 08/26/2009 02:13 PM, Daniel B. Thurman wrote:
On 08/26/2009 01:46 PM, Andrew Overholt wrote:
* Daniel B. Thurman<dant cdkkt com>  [2009-08-26 16:45]:
have to figure out if I can downgrade from v1.6x to v1.4x,
which may not be possible or is it?
I don't know.  If it's important, I suggest asking the subversion
maintainer.

Glad you got things straightened around,

Andrew

Ok, here is what I did:

1) yum remove eclipse-subclipse eclipse-svnkit
2) Added http://subclipse.tigris.org/update_1.4.x to update list,
    unchecked v1.6x tigris site
3) Commited the update, and got:

Cannot complete the request.  See the details.
Unsatisfied dependency: [org.tigris.subversion.subclipse.graph.feature.feature.group 1.0.7] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.gef/3.2.0 Unsatisfied dependency: [org.tigris.subversion.subclipse.graph.feature.feature.group 1.0.7] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.draw2d/3.2.0 Unsatisfied dependency: [org.tigris.subversion.subclipse.graph.feature.feature.group 1.0.7] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.draw2d/3.2.0 Unsatisfied dependency: [org.tigris.subversion.subclipse.graph.feature.feature.group 1.0.7] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.gef/3.2.0

so what can I do to remove the above conflicts in order
to resolve the commit?  Looks to me that it is the GEF,
DRAW components that are the problems and does not
appear that it is possible to downgrade these?

Looks to me that I am entering into 'uncharted waters' here!
Perhaps it's just not worth it, I dunno.

BTW: I forgot to add that when subclipse v1.6x tries to access
         a 1.4x repository - it "hangs", so there probably should
         be code to handle this case.  I also note that in F11,
         clicking the X (terminate) button on the window does
         not work - so that may mean the terminate handler does
         not work?

Dan

Ok, after painstaking work, I finally have gotten F11-eclipse
to work with v1.4x repositories.

The steps:

1) Remove subclipse v1.6x if installed w/:
    yum remove eclipse-subclipse svnkit

2) Make sure that most of all of the eclipse-* packages
    are installed - but not all.  If you install all of the
    eclipse-* packages you may run into problems as
    for me, eclipse would not launch.  I don't know which
    eclipse package causes this.  I avoided eclipse-nls*,
    eclipse-epic, eclipse-findbugs-contrib, eclipse-valgrind

3) Startup eclipse, then add: http://subclipse.tigris.org/update_1.4.x
    to the software install list, then select all items under
    the v1.4x category.

There is one snag left for me: I cannot get Eclipse's Ganymede
to launch - it hangs, nothing I have tried fixes this.  F11-Eclipse &
Galileo works fine.

Note1: If you reinstall F11-Eclipse after breaking it, make darn
sure that you blow away /usr/share/eclipse - there are "stuff there"
that somehow prevents F11-Eclipse from starting up - perhaps
old & corrupted files left behind after a F11-Eclipse corruption?
Also - you may be advised to first use Add & Remove package
installer - choose everything related to Eclipse there, then use
the above yum install for the rest of the packages.  This works
for me but it may because I yum install *eclipse*, not sure.

Note2: the very odd things about Ganymede was, at first it worked,
then after fuddling with F11-Eclipse and screwing it up, Ganymede
stopped working.

Cheers,
Dan


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]