[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Obtaining an RPM for the proper old atheros madwifi driver, not ath5k





On Fri, Dec 4, 2009 at 6:38 PM, James Allsopp <jamesaallsopp googlemail com> wrote:
I actually realised what I was doing wrong. The ath5k module came with the fedora kernel, but I've blacklisted it, and now  and got the madwifi drivers installed. I can now get the device into master with the correct ssid, but can't get ath0 to accept an ip address.

I tried to use ath5k, but need the 0.6 version of hostapd. There doesn't appear to be a rpm in any repository for this recently version. I don't want to leave my system in a mess by installing it manually, hence returning to madwifi.

Also I believe one of the users in this thread said that they couldn't get ath5k working as an ap, whereas I've had madwifi working as an ap before.

If anyone can show me the location of a 0.6 hostapd rpm, I'll try ath5k.

James



2009/12/4 Lonni J Friedman <netllama gmail com>

On Fri, Dec 4, 2009 at 10:44 AM, John W. Linville <linville redhat com> wrote:
> On Fri, Dec 04, 2009 at 04:17:18PM +0000, James Allsopp wrote:
>
>> I'm running Fedora 12, and was wondering if anyone knew of a repository
>> which contains one of hte old atheros drivers. I want to get rid of ath5k as
>> it doesn't seem to have a good reputation, sounds very experimental still,
>> and I can't make an access point with it without a hostapd0.6 rpm.
>
> Did you actually try ath5k?  Is obtaining a later hostapd really a
> bigger hardship than using an unmaintained, out-of-tree driver?
>
> If you have specific problems with ath5k then please cite them.
> Even better, open a bugzilla entry for them.  But please don't just
> spread random FUD.
>
> Madwifi is a dead project.  It does support a few oddball features
> (many of them non-standard) that some people need, mostly due to
> legacy use of Madwifi.  If you won't know what those are or why you
> need them, then you almost certainly should be using ath5k.
>

I should add that madwifi doesn't even work in F12 (possibly F11 too,
but I've not tried).  When I was having issues with ath9k, I actually
attempted to switch to madwifi out of desperation, and the kernel
modules wouldn't even load (when built from source).  Tons of missing
symbols.

Seriously, if you think problems with athXk are annoying, try getting
problems fixed with madwifi when its not even maintained and is likely
to not work at any time.


It works fine for me in F11 using ndiswrapper from ATrpms and the windows driver.
 
--
Paulo Roma Cavalcanti
LCG - UFRJ

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]