[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: can Fedora's QEMU run ppc guest in F12 x86_64 host?

On 12/05/2009 08:27 PM, Bill Davidsen wrote:
> Andre Robatino wrote:
>> I've tried to create a F12 ppc guest in a F12 x86_64 host, using F12's
>> Virtual Machine Manager and with qemu-system-ppc installed.  It's
>> reading a verified copy of Fedora-12-ppc-DVD.iso from the HDD.  It fails
>> with
>> CDROM boot failure code : 0004
>> Boot failed: could not read the boot disk
>> FATAL: No bootable device.
>> (Screenshot attached.)  At least this is an improvement over F11 which
>> would generate a kernel failure instead.  Is this supposed to work?  The
>> page
>> http://fedoraproject.org/wiki/Features/KVM_and_QEMU_merge
>> claims that it is.
> Were I you, I would take all the virtual "dumb it down" stuff out of the
> picture, create a 6GB or so qcow2 device with qemu-img, then run the ppc
> from the command line:
>   qemu-system-ppc64 -, 1200 -hda mydisk.img -cdrom install.iso -boot d
> -net nic
> look at the man page, those may not be exactly what you need for your
> system.
> I have found that this works when more convenient tools don't, due
> either to limitations in the tool or in the doc, or in my understanding.
> If this works it will point to the need to understand the convient tool
> better.

Good advice, I didn't know how to use QEMU on the command line.  I tried
making it work in the simplest way possible.  The following works with
an x86_64 image:

qemu-system-x86_64 -hda Fedora_12_x86_64.img -cdrom Fedora-12-x86_64-DVD.iso

but the corresponding command for ppc

qemu-system-ppc -hda Fedora_12_ppc.img -cdrom Fedora-12-ppc-DVD.iso

fails with the error

cd:0,\ppc\chrp\yaboot.conf: Unknown or corrupt filesystem
Can't open config file
Welcome to yaboot version 1.3.14 (Red Hat 1.3.14-23.fc12)
Enter "help" to get some basic usage information

I tried creating the .img file in both qcow2 and the default raw format,
and both the qemu-system-ppc and qemu-system-ppc64 commands.

Attachment: signature.asc
Description: OpenPGP digital signature

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]