[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: can Fedora's QEMU run ppc guest in F12 x86_64 host?



On 12/06/2009 08:40 AM, Bill Davidsen wrote:
> Andre Robatino wrote:

>> Good advice, I didn't know how to use QEMU on the command line.  I tried
>> making it work in the simplest way possible.  The following works with
>> an x86_64 image:
>>
>> qemu-system-x86_64 -hda Fedora_12_x86_64.img -cdrom
>> Fedora-12-x86_64-DVD.iso
>>
>> but the corresponding command for ppc
>>
>> qemu-system-ppc -hda Fedora_12_ppc.img -cdrom Fedora-12-ppc-DVD.iso
>>
>> fails with the error
>>
>> cd:0,\ppc\chrp\yaboot.conf: Unknown or corrupt filesystem
>> Can't open config file
>> Welcome to yaboot version 1.3.14 (Red Hat 1.3.14-23.fc12)
>> Enter "help" to get some basic usage information
>> boot:
>>
>> I tried creating the .img file in both qcow2 and the default raw format,
>> and both the qemu-system-ppc and qemu-system-ppc64 commands.
>>
> You need to tell it to boot off the cdrom. That's what the "-boot d"
> means. If that doesn't work I'll have to pull down a CD and try it.
> Also, is that ppc iso 32 or 64 bit? There's a 64 bit qemu as well.

It does boot off the cdrom (the default boot order is the usual one,
which tries the floppy first, then the cdrom, then the HD).  The x86_64
version works as expected, bringing up the install screen.  I got the
command line down to the shortest possible one.  I believe
Fedora-12-ppc-DVD.iso is 32-bit (sha256sum is
800ef4f121e178dcc9c8dc128825021949abe0d6d029f36cd47e39a4033c3aaa).


Attachment: signature.asc
Description: OpenPGP digital signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]