[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Booting sparkly new F12 install, error 13 from grub.



On Wednesday 09 December 2009, Tom H wrote:
>>>Well, according to the files present on /dev/sdb1, grub is installed.  I
>>>tried the chainloader+1, didn't work, now I'm about to reboot and try the
>>> map syntax to swap the bios drive orders.
>>
>> And that didn't work either. :(
>
>As I said in my earlier email, grub1 will not boot from an ext4 /boot.
>
Oh? ? ?

>From the cli, booted from /dev/sda:
[root coyote /]# mount -t ext3 /dev/sdb1 /mnt/sdb1
mount: wrong fs type, bad option, bad superblock on /dev/sdb1,
       missing codepage or helper program, or other error
       In some cases useful info is found in syslog - try
       dmesg | tail  or so

[root coyote /]# mount -t ext4 /dev/sdb1 /mnt/sdb1
[root coyote /]#

So, ext4 mounts, ext3 will not.  But if I switch the drives in the bios so 
that what is now /dev/sdb becomes /dev/sda, it works just fine, offering me 
the only kernel there to boot up, and it works.

>> I see by the grub file on the F12-x64 dvd that it is still grub-0.97 so
>> it isn't grub2, which I initially thought might be the problem.
>
>grub2 is able to boot from an ext4 /boot but let's not go there.
>
>> Is it safe to do a "grub-install /dev/sdb" from an F10 boot?
>
>If /boot were ext3, you would have to do mount your F12 partitions
>with (for example) a "root" partition of "/mnt" and then run
>"grub-install --root-directory /mnt /dev/sdb" (or "... (hd1)")
>
Is this then a partition install, and not an mbr install?

If I dd the first block of /dev/sda, then the first block of /dev/sdb, there 
are small diffs, but 95% identical, and neither is a carbon copy of the 
stage1 I catted just for S&G.

>Are you booting at the moment from /dev/sda or from a CD/DVD?

I can boot 2 os's from /dev/sda, including the mandriva-2009.1 on /dev/sdd 
simply by specing the correct /boot partition as a "root (hdN,0)" in the 
grub.conf stanza, except for F12, to boot that I have to switch the drives 
around in the bios.  But the root (hd1,0) fails for F12, forcing me to swap 
the drives in the bios before the F12 boot does anything but the error 13.

Do the drive swap in the bios, and it works, except I feel like I need to 
call a surveyor to set stakes and measure the erosion, its that slow once 
booted.

I have not tried a 'grub-install (hd1,0) or /dev/sdb1' as it ate my lunch the 
last time I had grub installed on 2 different drives.  I have NDI if that is 
allowed or not, or if I somehow screwed it up the last time I tried it.  I do 
recall I had to get out the F10 dvd, boot to it, and then do a "grub-install 
/dev/sda1" to restore booting ability at the time.

Thanks Tom.

-- 
Cheers, Gene
"There are four boxes to be used in defense of liberty:
 soap, ballot, jury, and ammo. Please use in that order."
-Ed Howdershelt (Author)
The NRA is offering FREE Associate memberships to anyone who wants them.
<https://www.nrahq.org/nrabonus/accept-membership.asp>

You give me space to belong to myself yet without separating me 
from your own life.  May it all turn out to your happiness.
		-- Goethe


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]