[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

F12 Upgrade Stumped



Getting more and more unhappy since F8.  Multiboot system with VISTA, F8 and
F10 with only minor Glitches in F10.  Tried to do preupgrade on the F10
partition.Things seemed to go alright until the reboot.  System locks up
with a blank screen.  The performance of the driver for the
	"Intel Corporation"
	"82945G/GZ Integrated Graphics Controller"
has been poor since F8.  The "i810" driver that gives good performance in F8
doesn't work for F10.  The "Intel" driver gives an offset screen.  It only
woks without an xorg.conf.  The result of system-config-display is a lockup. 
I filed a bug report long ago that I was notified was going away with F10
unless I could show that it was still in the newer system.

The stanza in grub was as follows:

title Upgrade to Fedora 12 (Constantine)
	kernel /boot/upgrade/vmlinuz preupgrade repo=hd::/var/cache/yum/preupgrade
stage2=hd:UUID=e990768e-e724-4250-bfc1-a25e0320e099:/boot/upgrade/install.img
ks=hd:UUID=e990768e-e724-4250-bfc1-a25e0320e099:/boot/upgrade/ks.cfg 
	initrd /boot/upgrade/initrd.img

The UUID agrees with what was in the F10 stanza.  I saw in the forum the
advice to add 

xdriver=vesa nomodeset

to the kernel line.  That change enabled the session to get a little
farther, but it then fails with a message  box that it can't find the root
of the system to upgrade.

Disk /dev/sda: 250.0 GB, 250059350016 bytes
255 heads, 63 sectors/track, 30401 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xf4fd4adf

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1              19        6949    55673257+   7  HPFS/NTFS
/dev/sda2               1          18      144553+  83  Linux
/dev/sda3            6950       30401   188378190    5  Extended
/dev/sda5            6950       13328    51239286    7  HPFS/NTFS
/dev/sda6           13329       13670     2747083+  82  Linux swap / Solaris
/dev/sda7   *       13671       22102    67730008+  83  Linux
/dev/sda8           22103       30401    66661686   83  Linux

Tried adding a root declaration to the kernel line but neither
root=/dev/sda7 nor

root=UUID=e990768e-e724-4250-bfc1-a25e0320e099

made any difference.

Tried the installation DVD but the text mode install won't recognize my disk
structure.  The graphical install locks up.  Is there a way to add the
"xdriver=vesa nomodeset" to the graphical startup?  The netinstall CD and a
liveCD all have the graphics problem.  I have the INTEL compiler suite and
MATHEMATICA on the system that don't stay nicely in /home.  Letting the text
mode install convert my partition to LVM would not be nice!!! 

Robert McBroom
-- 
View this message in context: http://old.nabble.com/F12-Upgrade-Stumped-tp26722237p26722237.html
Sent from the Fedora List mailing list archive at Nabble.com.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]