[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Universal drive adapter -

On 12/10/2009 03:07 PM, Bob Goodwin wrote:
>     I bought a new gadget, a "USB2 Universal Drive Adapter" which does
>     essentially what an external drive box does but it is not limited to
>     SATA drives,
>     On the F-12 computer it shows up in lsusb and I can see a drive at
>     /dev/sdc with fdisk [sdc1] and it shows up as Linux and LVM.
>     Is there a way to make it list the contents of the drive?
>     I tried mounting it with "mount /dev/sdc1 -t ext3 /mnt/hdtest" which
>     I created for the purpose but that doesn't satisfy it. It produces a
>     stock error message "wrong fs type, bad option, etc."
>     I've only tried that one old IDE drive so far. Any suggestions
>     appreciated.
>     Bob

You can use file to inspect the contents of the device:

# file -s /dev/sdc1


# file -s /dev/sda1
/dev/sda1: Linux rev 1.0 ext3 filesystem data (needs journal recovery)

# file -s /dev/sdc1
/dev/sdc1: x86 boot sector, code offset 0x3c, OEM-ID " mkdosfs",
sectors/cluster 4, root entries 512, Media descriptor 0xf8,
sectors/FAT 125, heads 3, sectors 127848 (volumes > 32 MB) , serial
number 0x4b21069a, label: "           ", FAT (16 bit)

The '-s' is needed to tell file to look at the device content and not
just report that this is a block device node.

The blkid command (part of util-linux) will also give useful
information on what devices contain:

# blkid /dev/sdc1
/dev/sdc1: UUID="4B21-069A" TYPE="msdos"


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]