[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Enabling Airport wireless on Macbook Air with F12



>>>>> "Colin" == Colin Paul Adams <colin colina demon co uk> writes:

    Colin> Thanks to Chris Smart, Peter Danenberg and others, I have
    Colin> been able to install Fedora 12 as the sole O/S on my
    Colin> Macbook Air (first generation).

    Colin> However the wirless networking is not enabled.  I am
    Colin> following the instructions in
    Colin> http://docs.fedoraproject.org/wireless-guide/f12/en-US/html-single/#chap-Wireless_Guide-Fedora_And_Wireless
    Colin> .

    Colin> There was no wireless device shown in the network
    Colin> Configuration, so I clicked New and added a device for
    Colin> hardware Apple Airport.  I also tried adding wireless
    Colin> device on the Hardware tab (eth0), but although it allows
    Colin> me to do this, after I save and then reopen the Network
    Colin> Configuration, the hardware only shows a device pan0 of
    Colin> Type Ethernet (which was there from the start). It does
    Colin> appear on the Devices tab (it didn't originally until I
    Colin> added it), but has staus of inactive, and no means to
    Colin> activate it.

    Colin> However, even after restarting the computer, the wireless
    Colin> icon on the panel says there are no network devices
    Colin> available.

    Colin> So I tried removing the device from control by
    Colin> NetworkManager, and activated it manually. But then I get:

    Colin> Device eth0 does seem to be present, delaying
    Colin> initalization.

    Colin> What do I need to do?

Apparently the answer is to forget about using Linux, and restore Mac
OSX :-( :-(

I did 

lspci

And discovered the device is a broadcom with PCI-ID of 14e4:4328 .

According to 

http://linuxwireless.org/en/users/Drivers/b43

This is not supported by the b43 device driver, so Linux on this
machine is not on.
-- 
Colin Adams
Preston Lancashire


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]