[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Some Thunderbird attachments don't start application



2009/12/18 Tim <ignored_mailbox yahoo com au>:
> On Fri, 2009-12-18 at 11:50 +0100, Antonio M wrote:
>> I got an attachment (Microsoft Office doc) but I didn't get the option
>> of F11 to open it with Openoffice or any other application, there is
>> no open with option, same attachment open  fine in F12, starting
>> Openoffice writer!!!
>
> Chances are that whoever sent you that file sent it with the wrong MIME
> type descriptor.  The sending client describes the type of file, and the
> receiving client passes that file off to the default application for
> that type of file.  If the *type* is not correctly outlined, then the
> whole system fails to work.
>
> Most likely, it was described as application/octet-stream which means
> "this is some unknown kind of binary file, figure out how to handle this
> by yourself."  If you try to set up your system to believe that all such
> unidentified files are word documents, by default, then you're setting
> yourself up for failure with the next NON word document that's sent with
> the *unknown* *binary* file type description.
>
> --
> [tim localhost ~]$ uname -r
> 2.6.27.25-78.2.56.fc9.i686
>
>

tnx for the great explanation, Tim.....I don't understand why same
attachment starts openoffice in F12 (two boxes) , that are both
standard installation.
What is different???


-- 
Antonio Montagnani
Skype : antoniomontag
SIP: antoniomontag ekiga net


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]