[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: mplayer fc12-86_64



On 12/19/2009 10:29 AM, Marko Vojinovic wrote:
On Friday 18 December 2009 21:52:12 david walcroft wrote:
On 12/18/2009 11:11 AM, david walcroft wrote:
I have the problem of constant flashing at start up of a movie.
I also tried other players (totem) they played videos but no sound,I
checked various volume levels and they were all at maximum.

[david reddwarf ~]$ mplayer kinema/garfield-tsr_m320.mov
Warning unknown option cache-prefill at line 148
MPlayer SVN-r29800-4.4.2 (C) 2000-2009 MPlayer Team
This codecs.conf is too old and incompatible with this MPlayer release!
at line 6

What do you have in ~/.mplayer/ directory? It looks like you have some stale
old files from previous versions of mplayer? Try renaming the directory and let
mplayer create a new directory for itself with default contents. Then try
playing the movie again.

I did but mplayer didn't write a default file

Playing kinema/garfield-tsr_m320.mov.
Cache fill:  0.00% (0 bytes)
libavformat file format detected.
[mov,mp4,m4a,3gp,3g2,mj2 @ 0x2f1be50]multiple edit list entries, a/v
desync might occur, patch welcome

I am not sure if this is because some confused options in the old config files
or the movie you're trying to play is badly encoded... Anyway it does warn you
that audio and video might get out of sync. I'm not sure if that amounts to
"flashing" you see or not.

AO: [alsa] 22050Hz 2ch s16le (2 bytes per sample)

Don't you have pulseaudio on by default? Try

   mplayer -ao pulse kinema/garfield-tsr_m320.mov

pulse is working as the sound had to be turned way up to hear it,
so I then found 'pavocontrol' and it's all under control now.

Plays well in the terminal but with out sound.

I'm not surprised there is no sound, given that it tries to use alsa instead
of pulseaudio.

Ok, three recommendations:

1) Try to play some other file. If it is fine, than this particular movie might
be broken somehow.

2) Rename ~/.mplayer/ directory to something else. If there are some old/wrong
config files and settings in there, they can confuse mplayer.

3) Check your sound configuration. Make sure pulseaudio is running, system
sounds and other music can be played without problems etc. Force mplayer to
use pulseaudio with "-ao pulse" option, although it *should* do it by default
anyway.

Btw, I understood that you were previously trying mplayer outside the
terminal, ie. using a GUI. What GUI were you using?

I was using mplayer-gui but I deleted it and installed gmplayer,it solved the problem.So now I have a working video system.

HTH, :-)
Marko




Thanks for your help Marko


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]