[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: F12 - Firefox (firefox-3.5.6-1.fc12) SQLite Version Error [WORKAROUND]



(My apologies for the random snips, up until just this afternoon I had
the Fedora mailing list coming in in archive format, which doesn't
really lend itself well to replying and keeping the message
threading).

> > I must be one of the very few people this has happened to, as Google
> > appears to have only pointed me at 'Bug 520339' (
> > https://bugzilla.redhat.com/show_bug.cgi?id=520339 ).

> Have you tried starting firefox from the command line with -safe-mode
selected?

Yes, I have, same result.

For the time being, I've basically reverted -all- software package
updates from 2009-12-18 forward by basically doing a:

  $ rpm -qa --last > list-file

and then saving a subset of those packages listed newer than
2009-12-18... later doing a:

  $ cat list-file | xargs echo | xargs sudo rpm -e --nodeps

...to remove them. Then I disabled all repos other than the original
fedora repo when reinstalling them, finally doing a:

  $ cat list-file | xargs echo | xargs sudo yum install -y

...which at least got firefox back to run-able state (whew). Here are
the versions from that previous package query, in case anyone's
interestd (although I'm guessing the real problem lies elsewhere).

  $ rpm -qa \*xulrunner\* \*firefox\* \*sqlite\*
  qt-sqlite-4.6.0-1.fc12.x86_64
  xulrunner-1.9.1.4-1.fc12.x86_64
  mono-data-sqlite-2.4.2.3-2.fc12.x86_64
  sqlite-3.6.20-1.fc12.x86_64
  firefox-3.5.4-1.fc12.x86_64

Finally, attached is the list of packages that were
removed/reinstalled. Sorry, I'd try and narrow down the culprit, but
this problem basically cost me a day of work and I'm short on time
right now. I'll revisit this and update back if I can narrow down the
real problem later.


--Mike

Attachment: list-file
Description: Binary data


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]