[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Preupgrade to F11 worked but...





Steve Blackwell wrote:
> 
> I ran preupgrade to go from F10 to F11 and I was pleasantly surprised
> (because F9->F10 was a mess) that it worked almost flawlessly. 
> 
> When I booted into F11 for the first time, I got a warning about a ssl
> library not being found. To cut a long story short, I have found that
> there are 62 packages that did not get updated from F10, one of them
> being httpd. I considered just deleting the offending rpm and
> reinstalling but there are so many dependencies.
> 
> Is this a common problem and how have others overcome it.
> 

Packages that don't have new dependencies or internal changes are not
relabeled with the version change.  Run from a root terminal session
yum clean all
yum update
to catch up with all the updates since the initial issue of F11.  If there
are missing dependencies use the 
--skip-broken 
option for yum if yum-utils is installed.  It is possible that there is an
selinux label problem.  Putting a zero length file with the name 
.autorelabel 
into / and rebooting will solve some problems.
If the library is still missing you'll have to do some sleuthing to find
where it was supposed to be found.

yum whatprovides libname

is useful.  

Robert McBroom
-- 
View this message in context: http://old.nabble.com/Preupgrade-to-F11-worked-but...-tp26869396p26892331.html
Sent from the Fedora List mailing list archive at Nabble.com.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]