[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Preupgrade to F11 worked but... [can't get httpd to start]



On Tue, 22 Dec 2009 11:18:59 -0800 (PST)
TNWestTex <mcforum bellsouth net> wrote:

> 
> 
> 
> Steve Blackwell wrote:
> > 
> > I ran preupgrade to go from F10 to F11 and I was pleasantly
> > surprised (because F9->F10 was a mess) that it worked almost
> > flawlessly. 
> > 
> > When I booted into F11 for the first time, I got a warning about a
> > ssl library not being found. To cut a long story short, I have
> > found that there are 62 packages that did not get updated from F10,
> > one of them being httpd. I considered just deleting the offending
> > rpm and reinstalling but there are so many dependencies.
> > 
> > Is this a common problem and how have others overcome it.
> > 
> 
> Packages that don't have new dependencies or internal changes are not
> relabeled with the version change.  Run from a root terminal session
> yum clean all
> yum update
> to catch up with all the updates since the initial issue of F11.  If
> there are missing dependencies use the 
> --skip-broken 
> option for yum if yum-utils is installed.  It is possible that there
> is an selinux label problem.  Putting a zero length file with the
> name .autorelabel 
> into / and rebooting will solve some problems.
> If the library is still missing you'll have to do some sleuthing to
> find where it was supposed to be found.
> 
> yum whatprovides libname
> 
> is useful.  
> 
> Robert McBroom
Thanks for the suggestions but they didn't help. 

I noticed that nearly all the fc10 packages that were left around were
-devel or -debug so I just deleted them. 

There were a couple that had no dependencies so I just yum removed and
then yum installed them.

I'm still having a problem with httpd. I yum removed it and its 10
dependencies and then re-installed them all (apart from bugzilla which
I don't need) but when I try to restart the service I get this error:

# run_init service httpd restart
Authenticating steve.
Password: 
Stopping httpd:                                            [FAILED]
Starting httpd: httpd: Syntax error on line 196
of /etc/httpd/conf/httpd.conf: Cannot
load /etc/httpd/modules/mod_file_cache.so into
server: /etc/httpd/modules/mod_file_cache.so: cannot open shared object
file: No such file or directory [FAILED]

Line 196 of /etc/httpd/conf/httpd.conf says:
LoadModule file_cache_module modules/mod_file_cache.so

yum whatprovides file_cache_modules says no matches


Steve.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]