[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Flash drive name change -



On 26/12/09 20:33, g wrote:
Bob Goodwin wrote:

I have not been able to change it no matter what I tried. And gparted tells me I've messed something up with it! After messing with gparted for a bit it tells me Partition and File System are "unallocated" whatever that means, but it sounds bad!
you no longer have a file system?


None of this is a serious problem, I guess I can reformat it ext2 and might eventually do that anyway. Just thought I should be able to do anything she can do with the Mac.
if you want ext2, would be best bet.

if you want to stay fat, use "mkdosfs -n".

my apoligies for leading you into problems with "dosfslabel". but from a
brighter side, you are gaining experience and will know how to handle next
time you get memory stixs.


hth.


mkfs.msdos -n fd3 /dev/sdc1 seems to have done it!

   [root box6 media]# mkfs.msdos -n fd3 /dev/sdc1

       mkfs.msdos 3.0.1 (23 Nov 2008)
       [bobg box6 ~]$ mount
       ...........  %<  .................

       /dev/sdc1 on /media/fd3 type vfat
       (rw,nosuid,nodev,uhelper=hal,uid=500,shortname=winnt,utf8)


Before doing that it would no longer mount, once I ran mkfs it mounted when plugged in. Fdisk said it was still formatted FAT32 so I haven't changed that yet. I guess the next thing will be to make certain I can still write to it as it is.

   Disk /dev/sdc: 4009 MB, 4009754624 bytes
   145 heads, 48 sectors/track, 1125 cylinders
   Units = cylinders of 6960 * 512 = 3563520 bytes
   Disk identifier: 0xc3072e18



       Device Boot      Start         End      Blocks   Id  System
   /dev/sdc1   *           1        1126     3915752    c  W95 FAT32 (LBA)

As for "leading me into problems," not to worry, I am quite able to find them without your help! And as you say it's been an interesting exercise.

Thanks for the help.

Bob




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]