[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: RAID 1 Mismatches



On Tuesday 29 December 2009 06:27:27 am Michael Cronenworth wrote:
> Rick Wagner on 12/28/2009 09:41 PM wrote:
> > 1) Where can the errors be coming from?  I would understand if a drive
> > were reporting errors.  Could it be during boot, one of the R-1 members
> > is being written too before MD is started?
> 
> If you have X running, you can start palimpset and view SMART data. If
> you don't have X running, you can run "devkit-disks --dump" to view
> SMART data. Look for "reallocated sectors", "uncorrectable sectors", or
> "pending sectors", and if they are not showing 0 for current value, then
> you have bad sectors forming.
> 

Hi Michael,

Thanks for the suggestions.  I did not find 'palimpset', but used the your 
'devkit' suggestion.  Looking at the physical device entries (i.e. 'sd[abc]
[1234]?') did not show anything like error counts.  I take that to mean there 
are no errors to be reported, though an affirmative entry of "no errors" 
errors would be more reassuring.  These are fairly modern drives, so I would 
expect that SMART would be supported on them, but wonder a little seeing the 
entry: "ATA SMART: not available".

Looking forward at other replies: I scanned the logs for interesting messages 
on sd[abc], not specifically for medium errors.  I expected that I had smartd 
running, but your later reply inspired me to verify, and I found it was not.  
Thanks for the reminder on that.

Below is a sample of the "devkit-disks --dump" for one of the physical 
devices, with the "not available" for the "ATA SMART" entry:

Other replies also imply that this is common if you have swap or mmaped files 
on the MD.  swap is on separate partitions, but I suppose the system or 
service may have some mmaped files (this is the root partition).

Thanks for the suggestions,
	--rick

========================================================================
Showing information for /org/freedesktop/DeviceKit/Disks/devices/sda
  native-path:             
/sys/devices/pci0000:00/0000:00:05.0/host0/target0:0:0/0:0:0:0/block/sda
  device:                  8:0
  device-file:             /dev/sda
    by-id:                 /dev/disk/by-id/ata-WDC_WD1001FALS-00J7B0_WD-
WMATV0665717
    by-id:                 /dev/disk/by-id/scsi-SATA_WDC_WD1001FALS-_WD-
WMATV0665717
    by-path:               /dev/disk/by-path/pci-0000:00:05.0-scsi-0:0:0:0
  detected at:             Tue 29 Dec 2009 11:17:52 AM PST
  system internal:         1
  removable:               0
  has media:               1 (detected at Tue 29 Dec 2009 11:17:52 AM PST)
    detects change:        0
    detection by polling:  0
    detection inhibitable: 0
    detection inhibited:   0
  is read only:            0
  is mounted:              0
  mount paths:
  mounted by uid:          0
  presentation hide:       0
  presentation name:
  presentation icon:
  size:                    1000204886016
  block size:              512
  job underway:            no
  usage:
  type:
  version:
  uuid:
  label:
  partition table:
    scheme:                mbr
    count:                 4
  drive:
    vendor:                ATA
    model:                 WDC WD1001FALS-0
    revision:              05.0
    serial:                WD-WMATV0665717
    ejectable:             0
    require eject:         0
    media:
      compat:
    interface:             ata
    if speed:              (unknown)
    ATA SMART:             not available


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]