[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: fedora-list Digest, Vol 59, Issue 267



I typed this in the terminal.
yum install totem-xine

Output:
Loaded plugins: refresh-packagekit
Setting up Install Process
Parsing package install arguments
Package totem-xine-2.24.3-1.fc10.i386 already installed and latest version
Nothing to do

Then I typed this in the terminal
 /usr/bin/totem-backend -b xine totem

After this when I trying to play a file like "dbgt35.rmvb" it starts playing the audio of that video file but it does not play the video .(black screen)

After this I also typed this in the terminal.
 /usr/bin/totem-backend -b xine totem-video-thumbnailer

Can anyone tell me what are these?
totem-audio-preview
totem-video-indexer
totem-video-thumbnailer
What do they do?

Now if I check from Movie Player>help>About
It says :Movie Player using xine-lib version 1.1.16.1

[Note:Same problem for gxine,dragonplayer,kaffeine.
They play the sound of the video file like "dbgt35.rmvb" but can't play the video.(only the black screen) and trying to play with mplayer, message :Could not open required direct show codec drvc.dll but it plays the video with this message]

rpm -qa | grep gstreamer

Output:
phonon-backend-gstreamer-4.2.0-7.fc10.i386
gstreamer-plugins-flumpegdemux-0.10.15-4.fc10.i386
gstreamer-tools-0.10.21-2.fc10.i386
gstreamer-plugins-bad-0.10.9-1.fc10.i386
gstreamer-plugins-base-0.10.21-2.fc10.i386
PackageKit-gstreamer-plugin-0.3.9-4.fc10.i386
gstreamer-plugins-bad-extras-0.10.9-1.fc10.i386
gstreamer-plugins-good-0.10.11-4.fc10.i386
gstreamer-plugins-farsight-0.12.9-3.fc10.i386
totem-gstreamer-2.24.3-1.fc10.i386
gstreamer-ffmpeg-0.10.5-1.fc10.i386
gstreamer-0.10.21-2.fc10.i386
gstreamer-plugins-ugly-0.10.10-2.fc10.i386
gstreamer-python-0.10.12-1.fc10.i386

rpm -qa | grep xine

Output:
xine-lib-extras-freeworld-1.1.16.1-1.fc10.i386
xine-lib-extras-1.1.16.1-1.fc10.i386
phonon-backend-xine-4.1.2-5.fc10.i386
xine-lib-1.1.16.1-1.fc10.i386
xine-0.99.5-5.fc10.i386
xine-lib-devel-1.1.16.1-1.fc10.i386
gxine-0.5.903-2.fc10.i386
totem-xine-2.24.3-1.fc10.i386

codecs are here:
/usr/lib/codecs
/usr/lib/win32
/usr/local/lib/codecs
/usr/local/lib/win32

Can anyone tell me the way to solve the problem.
Message: 7
Date: Sat, 31 Jan 2009 12:29:47 +0100
From: Gianluca Cecchi <gianluca cecchi gmail com>
Subject: Re: Problem with totem
To: fedora-list redhat com
Message-ID:
    <561c252c0901310329o54121b62u34703418bdf05d91 mail gmail com>
Content-Type: text/plain; charset=UTF-8

On Fri, 30 Jan 2009 08:01:45 -0800 (PST) GMS S wrote:
> Totem worked for me when i first installed Fedora 10.
> But after re-installation of Fedora 10 ,this problem occurs.
> Anyone knows the way solve this problem.
Tipically I use xine engine with totem, instead of gstreamer.
You can do:

yum install totem-xine

then you can use totem-backend to verify if setting xine as backend
solves the problem and eventually set it as the default engine for
totem.

[gcecchi tekkaman ~]$ totem-backend --help
Error: No backend name passed.
Usage:
- As root, to set the default backend, system-wide:
       /usr/bin/totem-backend -b <backend name>

- As a normal user, to run a program with a specific backend:
       /usr/bin/totem-backend -b <backend name> <program name>
[program options...]

- "backend name" is one of gstreamer or xine
- "program name" is one of totem, totem-audio-preview,
  totem-video-indexer or totem-video-thumbnailer

In totem gui you see the engine with
Help --> About
and with xine set you get in the window:
Movie Player using xine-lib version 1.1.16.1

HIH,
Gianluca


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]