[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: F10 - boot - how to get into interactive boot?



Robin Laing wrote, On 02/03/2009 09:37 AM:
Hello,

Sure, I know to press 'I' but on two machines, it has been a nightmare. One machine it never worked.

With faster machines, there is no time to press the button.

I found it wouldn't work if the normal Fedora splash screen was up on the screen. I had to press escape to get it to work. If I pressed to soon, the keyboard wouldn't work at all. It all happened so fast.

On the second machine, I never got it to work.

This machine has encrypted partitions and the password prompt makes it harder.

I can just get the Esc button pushed in time for the password to be requested. I then press 'I" right after pressing 'Enter.' I get a whole bunch of 'I's" before and after the notice but it still continues into udev and on into a normal boot. I never could get it to work.

Is there a way to get into interactive mode from grub?

When in the boot process is the keyboard input scanned for the Interactive? Before or after the message to press "I"?

And is it a "I" or "i"?  I have tried both.

I think I have had either work, though all is confusion as when I have to use it, for some reason I seem to be in panic/hurry up mode. :)



perhaps edit /etc/rc.d/rc.sysinit and add a `sleep 1` before and after the
 echo -en $"\t\tPress 'I' to enter interactive startup."
line.

If that works for you, may I suggest filing a bug against the output of
`rpm -q --whatprovides /etc/rc.d/rc.sysinit` such that the next version of that rpm includes the sleeps?


--
Todd Denniston
Crane Division, Naval Surface Warfare Center (NSWC Crane)
Harnessing the Power of Technology for the Warfighter


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]