[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

rpmbuild and getting Missing Dependency



Hi all.

I’m trying to build an rpm for lightsquid . I have got the rpm to build without any issues but now when I try and install it, it dies with missing dependencies the files are in the install list.  

 

[root gregory-workstation ~]# rpm -i /home/builder/rpm/RPMS/noarch/lightsquid-1.7-1.noarch.rpm

error: Failed dependencies:

                perl(common.pl) is needed by lightsquid-1.7-1.noarch

                perl(lightsquid.cfg) is needed by lightsquid-1.7-1.noarch

[root gregory-workstation ~]#

 

I have also used mc to browse the contents on the rpm and the files are in it.. so why do I get this error ?

 

Thanks

 

 

Regards

Gregory Machin

Email: gmachin techconcepts co za

Cell:   +27 (0) 72 524 5098

gtalk:  gmachin techconcepts gmail com

Support

helpdesk techconcepts co za

Tell:     +27 (0) 11 803 2169

Fax:     +27 (0) 11 803 2189

After Hours

Cell:    +27 (0) 82 790 0796

 


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]