[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: XFCE depends on GNOME, why?



On Fri, 06 Feb 2009 01:00:02 +0100
Kevin Kofler <kevin kofler chello at> wrote:

> Rahul Sundaram wrote:
> > A group in Fedora includes optional dependencies and the Xfce group
> > includes things like GDM and NetworkManager-gnome which will pull in
> > other dependencies.
> 
> I found at least one of the offenders: xfce4-xfapplet-plugin Requires:
> gnome-panel which Requires: pretty much all of GNOME. (And it has to
> because it's a wrapper which allows using GNOME applets in XFCE.)

Yep. Perhaps we should drop this from the Xfce comps group. 
:( 

> In F9 GA, there was also a Requires: gnome-panel in NM-gnome, but
> that one got fixed in F9 updates and F10 (which also helped KDE).
> 
> But none of these show up in the yum groupinstall output, so there
> must be another offender.

gdm is a big one. It now basically requires a gnome desktop to work. 
Perhaps we should look at pulling in kdm for Xfce. ;) 

> But indeed, not all the gnome-* packages are really GNOME, some are
> libs which are used by a lot of stuff, e.g. gnome-keyring. Packages
> like gnome-desktop, gnome-panel, control-center etc. are GNOME
> itself, it's when you're dragging these in that you have a problem.

Yep. 

>         Kevin Kofler

kevin

Attachment: signature.asc
Description: PGP signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]