[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: update to xorg-x11-drv-ati-6.10.0-1.fc10.x86_64 breaks X



| From: Bruno Wolff III <bruno wolff to>

| On Sun, Feb 08, 2009 at 15:20:04 -0500,
|   "D. Hugh Redelmeier" <hugh mimosa com> wrote:
| > X broke on me with recent updates.  Has anyone else experienced
| > a problem like this?
| 
| Yes. Some of these appear to be related to kernel modesetting as the bug(s)
| change with kernel versions. You might try using or not using the
| nomodeset kernel parameter. Depending on which kernel I am using, sometimes
| I need to use it and sometimes I must not use it.

Thanks for your ideas.

What are the symptoms of a modesetting problem?

My understanding is that it had to do with modelines: being able to
set arbitrary resolutions and refresh rates rather than just the ones
wired into the BIOS.

The symptoms here look different.

1) not recogunizing the DAC type (may not mattter)

2) not detecting the attached monitor's capabilities

Could these relate to mode setting?

| > | (II) RADEON(0): Port0:
| > |  Monitor   -- AUTO
| > |  Connector -- HDMI-B
| > |- DAC Type  -- TVDAC/ExtDAC
| > |+ DAC Type  -- None
| > |  TMDS Type -- UNIPHY
| > |  DDC Type  -- 0x7e50

| > | (II) RADEON(0): Output: HDMI-0, Detected Monitor Type: 0
| > |-Dac detection success
| > |+invalid output device for dac detection
| > This doesn't look good.

| > | (II) RADEON(0): EDID for output HDMI-0
| > | (II) RADEON(0): EDID for output DVI-0
| > | (II) RADEON(0): Manufacturer: DEL  Model: 4016  Serial#: 1194472500
| > I guess that means that my monitor is connected to DVI-0.

| > |-Output DIG2 dpms success
| > |+Output DIG0 dpms success
| > Does this difference mean anything?
| > It appears three times for some reason.

| > | Set CRTC 0 Source success
| > |-(II) RADEON(0): DIG2: Coherent Mode enabled
| > |-Output DIG2 setup success
| > |+Output DIG1 encoder setup success
| > |+(II) RADEON(0): DIG2 transmitter: Coherent Mode enabled
| > | Output DIG2 transmitter setup success
| > |-Output DIG2 dpms success
| > |+Output DIG0 dpms success
| > | Enable CRTC memreq 0 success
| > This seems confusing.  Why does the new config ever mention DIG2 when
| > it seems to have renumbered DIG2 to DIG0?
| > 
| > | Set CRTC 0 Source success
| > |-(II) RADEON(0): DIG2: Coherent Mode disabled
| > |-Output DIG2 setup success
| > |+Output DIG1 encoder setup success
| > |+(II) RADEON(0): DIG2 transmitter: Coherent Mode enabled
| > | Output DIG2 transmitter setup success
| > |-Output DIG2 dpms success
| > |+Output DIG0 dpms success
| > Similarly confusing.

| > | (II) RADEON(0): Output: HDMI-0, Detected Monitor Type: 0
| > |-Dac detection success
| > |-(II) RADEON(0): EDID for output HDMI-0
| > |-(II) RADEON(0): EDID for output DVI-0
| > |-(II) RADEON(0): Manufacturer: DEL  Model: 4016  Serial#: 1194472500
| > | ...
| > |-(II) RADEON(0): Modeline "640x480"x59.9   25.18  640 656 752 800  480 490 492 525 -hsync -vsync (31.5 kHz)
| > |-(II) RADEON(0): Output: HDMI-0, Detected Monitor Type: 0
| > |+invalid output device for dac detection
| > Lots and lots of juicy lines missing after update.
| > 
| > | (II) RADEON(0): Output: HDMI-0, Detected Monitor Type: 0
| > |-Dac detection success
| > |+invalid output device for dac detection
| > This sequence appears a bunch of times.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]