[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: F10 not connecting to wireless



2009/2/9 Bill Davidsen <davidsen tmr com>:
> Ian Malone wrote:
>>
>> Hi,
>>
>> I'm finally installing Fedora 10 x86_64 to replace a rather creaky
>> Fedora 6, and I can't connect to my wireless router. I was actually
>> looking forward to this working properly, as I had tried the Fedora 9
>> x86_64 live cd previously and it Just Worked (TM).  But in F10, both
>> x86_64 and i686, NetworkManager fails to get an IP.  Watching with
>> iwconfig while it's trying to connect I can see that the access point
>> is associating okay, but then it gives up trying to get a DHCP lease.
>> I've attached stderr from NM running in no-daemon mode under both F9
>> and F10 64 bit.
>>
>> Unfortunately I had a go at disabling NM and using the old
>> system-config-network approach too and this no longer works either.
>> Any suggestions?
>>
>> NIC is a Ralink rt2500.
>>
> If you are using excryption (WEP or WPA) I have a thought for you. Configure
> the NIC to sart at boot, not use NM, and after you come up log in and do a
>  "service network reload"
> and see if it comes up. FC9 worked for me uptil a NM "upgrade" after which
> it stopped working. After complaining about it to no avail, and debugging it
> to no solution, I concluded that NM tried to do the attach before
> wpa_supplicant was running, and the crypto failed. I could be all wet on
> that but this line
>  (sleep 30; service network reload) &
> in rc.local fixed my problem. When there's a live CD I will try it with FC11
> on that machine, or install to a flash drive.
>

Thanks, unfortunately this hasn't helped.  I'll have to try the old
'turn off encryption' trick too, however the card is associating with
the AP, this can be seen in both the NM output and if I watch with
iwconfig while doing either NM or ifup type connections.  That doesn't
rule out encryption problems, but I have seen NM unable to get DHCP
leases in the past F7/F8 on open networks
<https://bugzilla.redhat.com/show_bug.cgi?id=242469> (different
machine and wireless controller).

Incidentally, I'm not using wpa_supplicant either, this is a WEP
encrypted network.  I have tried starting the service though, but not
explicitly configuring it beyond anything that might be done by
system-config-network.

-- 
imalone


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]