[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Problem Deleting Directory & Files



On 11Feb2009 08:23, Patrick O'Callaghan <pocallaghan gmail com> wrote:
| On Tue, 2009-02-10 at 21:41 -0700, Kirk wrote:
| > I installed a tarball and then discovered I didn't need it.  I tried to
| > delete the director & files but permission gets denied.  I tried to
| > chmod but it wouldn't work on the files or directory.  I checked the
| > permissions which said I'm not the owner & can't change them.
| 
| If you're not the owner then you must have been superuser when you did
| the installation (or you were logged in as a different user). In any
| case, become that user again using 'su' and proceed.

On several UNIX platforms it's possible to give files away, and a tar
unpack quite often preserves the ownerships from inside the tar archive,
even as non-root. I'm fairly sure I've had this happen to me on Linux,
and so it's quite possible he wasn't root during the unpack.

Cheers,
-- 
Cameron Simpson <cs zip com au> DoD#743
http://www.cskk.ezoshosting.com/cs/

The reasonable man adapts himself to the world; the unreasonable one persists
in trying to adapt the world to himself.  Therefore all progress depends
on the unreasonable man.        - George Bernard Shaw


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]