[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Problem Deleting Directory & Files

On 11Feb2009 08:23, Patrick O'Callaghan <pocallaghan gmail com> wrote:
| On Tue, 2009-02-10 at 21:41 -0700, Kirk wrote:
| > I installed a tarball and then discovered I didn't need it.  I tried to
| > delete the director & files but permission gets denied.  I tried to
| > chmod but it wouldn't work on the files or directory.  I checked the
| > permissions which said I'm not the owner & can't change them.
| If you're not the owner then you must have been superuser when you did
| the installation (or you were logged in as a different user). In any
| case, become that user again using 'su' and proceed.

>On several UNIX platforms it's possible to give files away, and a tar
>unpack quite often preserves the ownerships from inside the tar >archive,
>even as non-root. I'm fairly sure I've had this happen to me on Linux,
>and so it's quite possible he wasn't root during the unpack.

There is another possible reason why that directory could not be removed. The 'immutable' bit or the 'undeletable' bit has been set. Use 'chattr -R -i -u <dirname>' and try again.


        Please let me know if anything I say offends you.
         I may wish to offend you again in the future.

         Tux says: "Be regular. Eat cron flakes."

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]