[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Please help! Lost my LVM VG...



Andrew Junev wrote:
Thursday, February 12, 2009, 9:42:38 PM, you wrote:


Running the command:

vgchange -ay VolTerabytes00

Should activate the VG, assuming that all PVs are present (and
any needed modules have been loaded).

I tried running lvm and it says "Locking type 1 initialisation
failed" no matter what command I enter...

Check that the file system providing /var has been mounted and is
 writable.

Assuming it's part of / you probably just need to run:

mount -n -oremount,rw /

Ah, that worked! Thank you!

What shall I do to automatically activate this VG during boot?

You need to understand why it wasn't being activated automatically.
Boot logs (dmesg and/or /var/log/messages) would help here. Normally,
devices are scanned for LVM metadata when rc.sysinit runs.

There were some bugs in older releases (f8 is no longer
supported/maintained) where udev would not wait long enough for some
devices to appear, causing these scans to "miss" the VG. That sounds
plausible here since the vgchange -ay worked after the system had
booted but there's not really enough information to say for sure.

Try adding a "sleep 5" or "udevsettle --timeout=30" command to
rc.sysinit above each of the LVM activation commands.

Regards,
Bryn.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]