[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: udev weirdness



Konstantin Svist wrote:
> Mikkel L. Ellertson wrote:
>> Konstantin Svist wrote:
>>   
>>> Hi,
>>>
>>> Using the tutorial at http://reactivated.net/writing_udev_rules.html,
>>> I've written a custom udev rule for my Zalman HD135 case - specifically,
>>> for the built-in VFD + IR receiver. The rule looks something like this:
>>>
>>> ACTION=="add", SUBSYSTEMS=="usb", ATTRS{idVendor}=="0403",
>>> ATTRS{idProduct}=="6001", SYMLINK+="lcd lcd-zalman-hd135"
>>>
>>> The problem is, sometimes (at reboot) it creates the symlinks to ttyUSB0
>>> (as it's supposed to) -- but other times to usbdev[...]. When it links
>>> to usbdev*, lirc and lcdproc don't work. If I run udevtrigger after the
>>> system is up, the symlinks are created correctly every time.
>>>
>>> My question is, why does this happen? It's almost as if ttyUSB0 is not
>>> created in time and the symlink gets assigned to the parent (as defined
>>> by udevinfo). Unfortunately, udev doesn't seem to allow me to write a
>>> rule that would match the final ttyUSB0 device...
>>>
> 
> 
One more dumb question - is that SUBSYSTEMS or SUBSYSTEM? It should
be SUBSYSTEM, but you posted SUBSYSTEMS

Mikkel
-- 

  Do not meddle in the affairs of dragons,
for thou art crunchy and taste good with Ketchup!

Attachment: signature.asc
Description: OpenPGP digital signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]