[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Fedora 8 upgrade to 9 missing dependency problem



I decided it was time to bite the bullet and upgrade my workstation to Fedora 9 from 8. I followed these instructions to upgrade using Yum:

  http://fedoraproject.org/wiki/YumUpgradeFaq

However when I ran the command:

  yum upgrade

I got a very long slew of "Missing Dependency" errors (see below). There are so many that I can't just uninstall all of the applications (might as well just do a clean install).

Can anyone suggest how I can troubleshoot this and resolve the issue? I have found a few people had similar issues, but saw no solution suggested.

Langdon



2:gimp-2.4.7-3.fc8.i386 from installed has depsolving problems
--> Missing Dependency: libpoppler-glib.so.2 is needed by package 2:gimp-2.4.7-3.fc8.i386 (installed)
wine-ldap-1.1.9-2.fc8.i386 from installed has depsolving problems
--> Missing Dependency: libldap_r-2.3.so.0 is needed by package wine-ldap-1.1.9-2.fc8.i386 (installed)
httpd-tools-2.2.9-1.fc8.i386 from installed has depsolving problems
--> Missing Dependency: libssl.so.6 is needed by package httpd-tools-2.2.9-1.fc8.i386 (installed)

<snip> Removed about 100+ lines of dependency errors ...

Error: Missing Dependency: libcrypto.so.6 is needed by package php-mysql-5.2.6-2.fc8.i386 (installed) Error: Missing Dependency: libssl.so.6 is needed by package 6:kdebase-3.5.10-2.fc8.i386 (updates-newkey) Error: Missing Dependency: perl(:MODULE_COMPAT_5.8.8) is needed by package foomatic-3.0.2-67.fc8.i386 (installed) Error: Missing Dependency: libcrypto.so.6 is needed by package qt4-x11-4.4.3-1.fc8.i386 (installed) Error: Missing Dependency: libsilc-1.0.so.2 is needed by package libpurple-2.5.2-1.fc8.i386 (installed) Error: Missing Dependency: libldap-2.3.so.0 is needed by package 6:kdebase-3.5.10-2.fc8.i386 (updates-newkey)


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]