[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Fedora 8 upgrade to 9 missing dependency problem



On Sat, 21 Feb 2009, Langdon Stevenson wrote:

Error: Missing Dependency: libcrypto.so.6 is needed by package php-mysql-5.2.6-2.fc8.i386 (installed) Error: Missing Dependency: libssl.so.6 is needed by package 6:kdebase-3.5.10-2.fc8.i386 (updates-newkey) Error: Missing Dependency: perl(:MODULE_COMPAT_5.8.8) is needed by package foomatic-3.0.2-67.fc8.i386 (installed) Error: Missing Dependency: libcrypto.so.6 is needed by package qt4-x11-4.4.3-1.fc8.i386 (installed) Error: Missing Dependency: libsilc-1.0.so.2 is needed by package libpurple-2.5.2-1.fc8.i386 (installed) Error: Missing Dependency: libldap-2.3.so.0 is needed by package 6:kdebase-3.5.10-2.fc8.i386 (updates-newkey)

These are the ones you really need to understand. They aren't necessarily the problem themselves, but could indicate that some package doesn't have an update patch and is requiring the old version. I am however confused by the line
Error: Missing Dependency: libldap-2.3.so.0 is needed by package
6:kdebase-3.5.10-2.fc8.i386 (updates-newkey)
which suggests you are still looking at a Fedora 8 updates-newkey, and not a Fedora 9 one.

I also notice that kdebase in version 4 not 3 in Fedora 9, and version 3 libraries are provided by the kdebase3 package. You could try
yum install kdebase3
and see what happens.

An alternate approach is to use preupgrade.

	Michael Young



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]