[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Fedora 10 64-bit & Wired Network Problems



Rick Bilonick wrote:
I installed F10 64-bit from the DVD iso on a 64-bit Intel 4-cpu
computer. I had problems getting the wired network connection to work on
network "A" UNTIL I realized that the "network" daemon was for some
reason turned off by default. Once I turned it on via services,
networking worked fine (using a static IP). (There is an annoying bug in
the F10 gui for networking - the net mask gets changed to the gateway ip
which of course screws up networking - this appears to be fixed once you
upgrade the system but I had to manually fix the eth0 script to get the
netmask to the correct value.)

Now I've installed the same DVD iso on a dual 64-bit AMD Opteron system
that previously had run F8 (networking worked fine on network "A"). I've
made sure network is on. I've manually configured the eth0 script to
avoid the buggy network gui netmask problem. I can ping the gateway on
network "A". For some reason I cannot ping the DNS on this network. I
can connect to my home computer using its IP address using ssh. But I
cannot view web pages using the URL's. I switched to a different
ethernet port on a "different" network "B" with different fixed IP and
DNS that I know works (I use it for my F8 laptop every day) and although
I can ping the gateway and DNS, I still cannot view web pages. I just
now hooked my Ubuntu 8.10 laptop to network "A" and it connects
flawlessly and I can view web pages so I know the port works - both
ports on networks "A" and "B" work fine. But I cannot get the F10 AMD
computer to connect to either network and view web pages (I do as I said
get some connection using IP addresses and ssh).
Any ideas on what is wrong? This is very frustrating. If I could get a
network connection I could upgrade the computer but I can't get to
square one.

P.S. I've looked at the eth0 script, the resolv.conf and hosts files and
everything looks fine. I've tried turning different things on and off
(like IPv6 and peer) but nothing makes a difference. I'm using DNS1,
DNS2, and DNS3 in the eth0 script and these appear appropriately in the
resolv.conf file.

I have never had this much trouble getting a wired network connection -
it almost always works by default.

Rick B.


My rule for this issue is to remove network manager.

On two desktop computers with static IP addresses was.

-install F10 from DVD.
-apply all the updates.
-install yumex.  {I like it better than packagekit}
-install system-config-network
-turn off networkmanager
-remove networkmanager
-run system-config-network
-enter in settings
-restart networking
-ensure networking is running properly
-test by rebooting.

As others have suggested, check /etc/sysconfig/network*
as well as /etc/resolve.conf


--
Robin Laing


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]