[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: can't log in after converting root filesystem



On Sat, Jan 3, 2009 at 11:01 AM, fred smith
<fredex fcshome stoneham ma us> wrote:
> On Sat, Jan 03, 2009 at 10:34:24AM -0800, Alan Evans wrote:
> I discovered (on my eeepc 901) that adding "relatime" to /etc/fstab causes
> subsequent kernel installs to go bad in that they create  bad initrd file
> and causing boot to fail with complaints about relatime being an unknown option.

I read the bug about relatime, but didn't think it was applicable,
relatime being somewhat more recent than noatime. I guess I don't
really have a preference between. I don't run any automated backup
software.

> did you try booting the previous kernel to see if it will work for you? If it
> does,  you could then remove the noatime from /etc/fstab, recreate the
> initrd for the new kernel, the re-add the noatime and try booting the new
> kernel. (see man initrd for guidance.)

Anyway, I tried it. Removed noatime from fstab. (Booting old kernel
did work.) Ran mkinitrd with no optional parameters. Still no joy.

If I change the fstype back to ext3 and run mkinitrd then the system
boots with apparently no problem. Then I can change fstab back to ext2
and reboot and it works.

But it all seems wrong to me. I presume I need to jack this around
again before and after every kernel update. And since the initrd still
thinks the filesystem is ext3, I can't ever run tune2fs to actually
convert it to ext2 lest the initrd choke on it.

Yuck. I hope someone's working on this. Is there a bugzilla somewhere?
I looked, but didn't find anything specifically similar to my problem.
And what of the installer ignoring my preference for ext2? At this
point I figure that if it had honored my instruction, I would have had
an unusable system from the beginning...

Hoping there's a better answer!

-Alan


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]