[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Firefox 3.05 attempting to execute code on stack



On Thu, Jan 8, 2009 at 10:51 AM, Dave Feustel <dfeustel mindspring com> wrote:
> On Wed, Jan 07, 2009 at 03:14:39PM +0000, Bryn M. Reeves wrote:
>> Dave Feustel wrote:
>>> On Wed, Jan 07, 2009 at 02:54:06PM +0000, Bryn M. Reeves wrote:
>>>> Dave Feustel wrote:
>>>>> SELinux is reporting attempts by Firefox 3.05-1 to execute code
>>>>> on the stack on 32-bit f9. Time for a Firefox upgrade?
>>>>>
>>>> Java plugin?
>>>>
>>>> Bryn.
>>>
>>> I have no idea. Maybe something to do with Flash.
>>
>> Possibly, although I doubt it - I've never seen a flash plugin that
>> attempted this but I have seen a number of JVMs do it (I assume it's
>> something to do with jit), mostly older ones iirc, so it's probably
>> worth checking for updates if you have a JRE installed that's not part
>> of the distribution.
>>
>> Bryn.
>
> The offending file is a plugin called npviewer. Java was updated
> yesterday. I think this was activated as a result of my attempts
> to get Flash working with Firefox.

It's part of nspluginwrapper. I've been getting segfaults from this
for several months, though it doesn't seem to actually break anything
I use.

poc


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]