[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Why Fedora 10 still uses openssl pkg from 2007, 4 releases old?



Rick Stevens wrote:
> Thus, if you installed a libssl.so.8 and DIDN'T create (or replace) a
> ".so.7" symlink which points at the new .8 version to satisfy existing
> packages

That's an extremely bad idea!
1. RPM ignores such symlinks, so they won't actually satisfy the deps.
2. The soname was bumped for a reason! Your symlink subverts that and is
likely to lead to crashing programs.

        Kevin Kofler


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]