[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: LibUSB/LibFTDI permissions problem



Thank you very much for your reply,

On Fri, 2009-01-09 at 00:44 -0900, Jeff Spaleta wrote:
> On Fri, Jan 9, 2009 at 12:12 AM, Dmitri Bachtin <damg dev googlemail com> wrote:
> > Additionally: after closing the device on execution as root, it gets
> > removed and the converter has to be replugged.
> That I'm not sure about.  I'll have to try to reproduce that with the
> FTDI based usb to serial breakout boards I have on hand.
> 

it actually gets already removed after opening the device, not closing.
My observation was wrong. I've pasted `udevmonitor /dev/ttyUSB0` to
http://rafb.net/p/CY7p2S91.html and sample code at
http://rafb.net/p/OmEu0t95.html in hope it might be of use. When
sleep(...) hit, the device file was already away. After a
ftdi_usb_find_all(...) it is still there.

> 
> ...
> As for the permissions... look at configuration PolicyKit to change
> the authorizations for serial modems

> ...

> -jef
> 

As you suggested, I used PolicyKit to provide direct access to serial
modems. Here is my `polkit-auth --user` output:
http://rafb.net/p/3dtITs74.html .

"org.freedesktop.hal.device-access.modem" is now listed in the output.

I tried defining explicitly my user and played with global access
options, replugged the device and rebooted. The result is unfortunately
still the same: inappropriate permissions on device.

Best regards,
 -- Dmitri Bachtin


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]