[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Need help with WLAN on Eee PC 1000H



On Mon, Jan 12, 2009 at 10:01:39PM +0100, Adalbert Prokop wrote:
> Hello!
> 
> Last week I wrote to the fedora-laptop list, bo nobody there was able to 
> help me. I need your help with my WLAN on a Asus Eee PC 1000H. It has a 
> Ralink WiFi card
> 
> --- 8< --- 8< --- 8< --- 8< --- 8< --- 8< ---
> 01:00.0 Network controller [0280]: RaLink Device [1814:0781]
>         Subsystem: RaLink Device [1814:2790]
>         Flags: bus master, fast devsel, latency 0, IRQ 19
>         Memory at fbef0000 (32-bit, non-prefetchable) [size=64K]
>         Capabilities: <access denied>
>         Kernel driver in use: rt2860
>         Kernel modules: rt2860sta
> --- 8< --- 8< --- 8< --- 8< --- 8< --- 8< ---
> 
> I configured the rpmfusion repository and installed the rt2860
> package. There was a small caveat - I had to do "iwpriv ra0 radio_on" in
> order to do anything related with WLAN, but afterward scanning was

On my eeepc 901 (also using the ralink chipset) I had to do none of that.
I installed the kmod package of the rt2860 driver (I've since learned
that the akmod package may have been a better choice), and NM came up 
and I connected. as simple as that.

> possible. But I can't connect my AP using Network Manager. Basically I
> see those two lines in wpa_supplicant.log
> 
> Trying to associate with 00:18:f3:85:6a:31 (SSID='memphis' freq=2437 MHz)
> Authentication with 00:00:00:00:00:00 timed out.
> 
> NM keeps asking me for a password, but my input is definitely correct.
> 
> So I thought NM messes things up (as was my experience with my old
> notebook) and I tried to get WLAN running using iwconfig +
> wpa_supplicant configuration directly. Here is my wpa_supplicant.conf I
> used.
> 
> --- 8< --- 8< --- 8< --- 8< --- 8< --- 8< ---
> ctrl_interface=/var/run/wpa_supplicant
> ctrl_interface_group=wheel
> 
> network={
>         ssid="memphis"
>         scan_ssid=1
>         psk="myverysecretpassword"
> }
> --- 8< --- 8< --- 8< --- 8< --- 8< --- 8< ---
> 
> But it did not work either, the Eee PC still could not connect to the AP.
> 
> The only way I can establish a WLAN connection is to compile the rt2860
> driver from the Ralink homepage
> (http://www.ralinktech.com/ralink/Home/Support/Linux.html) without any
> patches and configure it *only* for wpa_supplicant support, not NM
> support! Then and only then I can connect to my AP using WPA *but* I
> have to use iwpriv command to set the encryption password! (iwpriv set
> WPA=secret)
> 
> Did you succeed in using WLAN with F10 on Eee PC 1000H and if yes - how 
> did you do it? Do you have an idea how to convince Ralink's chip to 
> behave "normally"?
> I've ran out of ideas what else to try. Do you see a point I'm obviously
> missing? I've search the net, but it seems to work for everybody else,
> contradicting my experience.

Before I blew away the xandros-drived Linux that came on the 901 I had
a lot of trouble getting wireless to work. One of the things I had to do
to get it working is tweak a few settings on my wireless router. Have you
tried (temporarily) relaxing some security features to see if you can get
it going?

There has also been some discussion of similar issues on the fedora forums. 
there's a topic on putting F10 on eeepc 901 and 1000 that has discussed
a number of things, including wireless issues, that you may wish to
check out.

-- 
---- Fred Smith -- fredex fcshome stoneham ma us -----------------------------
  "For him who is able to keep you from falling and to present you before his 
 glorious presence without fault and with great joy--to the only God our Savior
 be glory, majesty, power and authority, through Jesus Christ our Lord, before
                     all ages, now and forevermore! Amen."
----------------------------- Jude 1:24,25 (niv) -----------------------------

Attachment: pgpbIV8pWvfIB.pgp
Description: PGP signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]