[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Preupgrade F8 to F10: a short story



Timothy Murphy wrote:
> I ran preupgrade on an ancient Thinkpad T20
> which was running Fedora-8.
> (I hadn't used it for a year or so.)
> 
> Preupgrade seemed to run OK,
> but when I re-booted for the second time
> (ie after installing the upgrade)
> I got the dreaded GRUB message,
> which I take to mean that the grub installation
> has got itself screwed up in some way.
> 
> I got out my trusty Knoppix-5.1 CD,
> which saw everything on my hard disk clearly,
> mounted /dev/hda8 as /mnt/hda8 and /dev/hda2 as /mnt/hda8/boot ,
> and chroot-ed to /mnt.hda8 .
> But when I ran
> 	#grub
> 	#grun> root (hd0,1)
> I got the message
> 	Error 21: Selected disk does not exist
> 
> To cut a long story short, when I ran
> 	#/mnt/hda8/sbin/grub
> I no longer got this message, and was able to install grub with
> 	#setup (hd0)
> 
> Just a story, with no moral.
> 
> 
One thing for future reference - you need /boot mounted where it
normally is in relation to / for this to work correctly.

It also works better if you chroot to the / directory...

Mikkel
-- 

  Do not meddle in the affairs of dragons,
for thou art crunchy and taste good with Ketchup!

Attachment: signature.asc
Description: OpenPGP digital signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]