[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Preupgrade F8 to F10: a short story



Craig White wrote:

>> > I ran preupgrade on an ancient Thinkpad T20
>> > which was running Fedora-8.
>> > 
>> > Preupgrade seemed to run OK,
>> > but when I re-booted for the second time
>> > (ie after installing the upgrade)
>> > I got the dreaded GRUB message,
>> > which I take to mean that the grub installation
>> > has got itself screwed up in some way.
>> > 
>> > I got out my trusty Knoppix-5.1 CD,
>> > which saw everything on my hard disk clearly,
>> > mounted /dev/hda8 as /mnt/hda8 and /dev/hda2 as /mnt/hda8/boot ,
>> > and chroot-ed to /mnt.hda8 .
>> > But when I ran
>> > #grub
>> > #grun> root (hd0,1)
>> > I got the message
>> > Error 21: Selected disk does not exist
>> > 
>> > To cut a long story short, when I ran
>> > #/mnt/hda8/sbin/grub
>> > I no longer got this message, and was able to install grub with
>> > #setup (hd0)

>> The disk is called sda (sd0) now, not hda (hd0).
> ----
> No - this is grub and it is only interested in enumerating hard drives
> in a sequential order but does not differentiate with the kernel module
> - this is before kernel modules actually are loaded.
> 
> hd0 is the correct terminology for grub

Quite.
I did wonder, however, if the problem might be
that /boot/grub/device.map had /dev/sda
and this might confuse the Knoppix grub.
But I changed it (temporarily) to /dev/hda
and still got the same error message.

Running the Knoppix grub interactively
I could not find any "root" that worked -
every attempt ended in "disk does not exist".
Equally, all attempts to "find" stage1, etc, failed.





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]