[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Need help with WLAN on Eee PC 1000H



Hi Adalbert,

I have two of these EeePC 1000h, and WPA2 is not supported by the default Linux OS installed,

I installed Fedora 10 via PXE boot (using a network cable) slooowwww.. but it worked out of the box.

I installed KDE only - which looks great cos the black theme matches the black version of this machine so well - oops getting off track.

I then downloaded and compiled the 2008_0918_RT2860_Linux_STA_v1.8.0.0.tar.bz2 as per this thread:

http://forums.fedoraforum.org/showthread.php?t=199434 (details you need at listed below).

However, I'm using the newer version 1.8 (and there may be a newer one since, have not checked), I cannot remeber if it patched (sta_ioctl.patch) cleanly or not or even if you need the patch in the newer version, anyhow, reboot and it should work when you login.

TIP: If you have a USB Stick (mine was 1GB) unzip and compile the drivers directly on that or better still, compile it on an NFS mount cos the SDD disk is really slow :( (this does not effect the everyday performance).

Also, don't mess with wpa_supplicant and what not (i.e chkconfig etc) , just let NetworkManager do it's stuff.

WPA2 works perfectly using this (and the network is very reliable).

I also installed a PAM module that automatically logged on to the wireless when I log in (cos having to type in the Key Manager password every time I login was just plain annoying).

(What would be nice is if it would connect via Wireless when in init 3 (like the cable) and use that connection for each user - and I think that's on the cards for NetworkManager in the future).

INSTRUCTIONS FROM LINK ABOVE:

1. To be able to compile the driver we need a few extra packages. In the terminal (as root), type
Code:

yum install gcc kernel-devel kernel-headers

2. Obtain the latest Ralink driver here (1.7.0.0 at the time of writing this post)
3. Unzip the driver to a directory.
4. Open the directory, and go to 2008_0708_RT2860_Linux_STA_v1.7.0.0/os/linux/rt_main_dev.c 5. Look up "dev->nd_net" and replace it with "dev_net(dev)", then save the file and close it (thanx
toCiaran McCreesh’s Blag for this tip).
6. Open 2008_0708_RT2860_Linux_STA_v1.7.0.0/os/linux/config.mk and change "HAS_WPA_SUPPLICANT" and
"HAS_NATIVE_WPA_SUPPLICANT_SUPPORT" to "y".
7. Download hdp's patch, and copy it to 2008_0708_RT2860_Linux_STA_v1.7.0.0/os/linux 8. Open a terminal, cd to 2008_0708_RT2860_Linux_STA_v1.7.0.0/os/linux and type "patch sta_ioctl.c
sta_ioctl.patch"
9. From the terminal cd to 2008_0708_RT2860_Linux_STA_v1.7.0.0 and type "make", it should finish without
any errors.
10. Type "make install", then when finished, exit the terminal.
11. If you restart the Eee PC and enable the wireless from the BIOS, it should be recognized without
problems.


Best of luck.

Albert.




Adalbert Prokop wrote:
Hello!

Last week I wrote to the fedora-laptop list, bo nobody there was able to help me. I need your help with my WLAN on a Asus Eee PC 1000H. It has a Ralink WiFi card

--- 8< --- 8< --- 8< --- 8< --- 8< --- 8< ---
01:00.0 Network controller [0280]: RaLink Device [1814:0781]
        Subsystem: RaLink Device [1814:2790]
        Flags: bus master, fast devsel, latency 0, IRQ 19
        Memory at fbef0000 (32-bit, non-prefetchable) [size=64K]
        Capabilities: <access denied>
        Kernel driver in use: rt2860
        Kernel modules: rt2860sta
--- 8< --- 8< --- 8< --- 8< --- 8< --- 8< ---

I configured the rpmfusion repository and installed the rt2860
package. There was a small caveat - I had to do "iwpriv ra0 radio_on" in
order to do anything related with WLAN, but afterward scanning was
possible. But I can't connect my AP using Network Manager. Basically I
see those two lines in wpa_supplicant.log

Trying to associate with 00:18:f3:85:6a:31 (SSID='memphis' freq=2437 MHz)
Authentication with 00:00:00:00:00:00 timed out.

NM keeps asking me for a password, but my input is definitely correct.

So I thought NM messes things up (as was my experience with my old
notebook) and I tried to get WLAN running using iwconfig +
wpa_supplicant configuration directly. Here is my wpa_supplicant.conf I
used.

--- 8< --- 8< --- 8< --- 8< --- 8< --- 8< ---
ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=wheel

network={
        ssid="memphis"
        scan_ssid=1
        psk="myverysecretpassword"
}
--- 8< --- 8< --- 8< --- 8< --- 8< --- 8< ---

But it did not work either, the Eee PC still could not connect to the AP.

The only way I can establish a WLAN connection is to compile the rt2860
driver from the Ralink homepage
(http://www.ralinktech.com/ralink/Home/Support/Linux.html) without any
patches and configure it *only* for wpa_supplicant support, not NM
support! Then and only then I can connect to my AP using WPA *but* I
have to use iwpriv command to set the encryption password! (iwpriv set
WPA=secret)

Did you succeed in using WLAN with F10 on Eee PC 1000H and if yes - how did you do it? Do you have an idea how to convince Ralink's chip to behave "normally"?
I've ran out of ideas what else to try. Do you see a point I'm obviously
missing? I've search the net, but it seems to work for everybody else,
contradicting my experience.

Any help is *very* appreciated.



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]