[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: mount question [SOLVED]



---- "Mikkel L. Ellertson" <mikkel infinity-ltd com> wrote: 

> > I'll try changing the type from fuse to ntfs tonight and see what
> > that does. The error message of "permission denied" leads me to
> > think that this will not solve the problem but hey, I've been wrong
> > before...1982 I think it was... ;-D
> > 
> > I have to say though that I am really suprised that nobody on this
> > list can give a simple answer to the seemingly simple question of
> > "how do I change the mount point of a hard drive".
> > 
> > Steve.
> > 
> Maybe it is more of a problem with the subject that you used?
> Something on the order of:
> 
> /dev/sdb1 /mnt/c_drive ntfs-3g <options> 0 0
> 
> It worked fine for me in F8 for mounting a NTFS partition.
> (Different names...)

Thanks, Mikkel. 
The solution was as simple as using the correct type, ntfs-3g, in the /etc/fstab file.
My Windows partition is now mounted n the "correct" place which allowed my USB drive to go back to /media/disk instead of /media/disk-1 and so now my backups are working again. I completed full backups last night and so my next task is to upgrade to F9 using a DVD since preupgrade doesn't work for me.

I'm still left with many questions that I think are not so easy to answer.

What overwrote my fstab file in the first place?
Why did it get overwritten without any notification?
Why did whatever overwrote it decide for me that my Windows partition should be removed?
Why does mount report that a filesystem is of type fuseblk when the type requested was ntfs-3g?
Why is there no mention of type fuseblk in the mount man page or in the fstab man page?man mount
Why does mount report "permission denied" instead of something like "bad type" when it gets an incorrect type?

Steve.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]