[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: F10 Installation: Unable use Add/remove packages or Yum [SOLVED]



Daniel B. Thurman wrote:
Ralf Corsepius wrote:
Daniel B. Thurman wrote:

F-10 Repository:
Fedora 10 - i386
Fedora 10 - Updates

1. Add/Remove Software:
No results were found.
Try entering a package name in the search bar.

2. Yum update
Loaded plugins: refresh-packagekit
Could not retrieve mirror list http://mirros.fedoraproject.org/mirrorlist?repo=fedora-10&arch=i386 error was
[Errno 4] IOError: <urlopen error (-2, 'Name or service not known')>
Error: Cannot retrieve repository metadata (repomd.xml) for repository: fedora,
Please verify its path and try again.

What do I need to do to fix this, please?
You have a typo in the URL above:

http://mirrors.fedoraproject.org/mirrorlist?repo=fedora-10&arch=i386
would be correct (mirrors.fedoraproject.org instead of mirros.fedoraproject.org)

Ralf

Yes, I mis-typed it by hand - the repos are correct as you have stated.

I am still not able to access the Internet which is why I think it is failing
to begin with.  I am trying to figure out exactly what is preventing F10
from reaching my default router, (Internet) at this point.

I have checked, and successfully pinged, yahoo.com from the Terminal window.
This means: ping yahoo.com was successfully returning timing results, also means
that yahoo.com was successfully DNS resolved into an IP address.

Since Firefox failed to work using the FQDN in the URL, I suspected that the DNS resolver was not resolving in this application, so, I obtained the IP address of fedoraproject.org via nslookup, and placed the IP address into the Firefox URL,
and it worked.

So, I checked /etc/resolv.conf and discovered, that there was a DNS IP address that was not working (ie, the DNS system was returning bad results, so I removed
it), now, at this point, yum is now working. HooBoy.

Sorry for posting all of this, as it turns out, it was my fault, not F10.

Dan


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]