[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: updateing ARGHH.



Kam Leo wrote:
On Mon, Jan 19, 2009 at 9:58 AM, Michael Comperchio <mcmprch gmail com> wrote:
Mikkel L. Ellertson wrote:
Michael Comperchio wrote:

When I run the 'Update System' 'cuz it's telling me I have updates... I
get the following errors:

libavcodec.so.51 is needed by package gstreamer-ffmpeg-0.10.5-1.fc10.i386
libavcodec.so.51 is needed by package
xine-lib-extras-freeworld-1.1.16-1.fc10.i386
libavcodec.so.51 is needed by package
k3b-extras-freeworld-1.0.5-4.fc10.i386 : Success - empty transaction

and the update fails. Unfortunately for the silly updater...I HAVE that
file install in /usr/lib... in fact I have .51 .51.71 and .52 installed
... what's up?

TIA
Michael


It is telling you that it could not update libavcodec because it is
needed by those packages.

Mikkel

OK, I guess I'm missing something. It did NOT do the updates. But I have
those files!
Michael

Different versions. You have older. Update wants to install newer.
Already installed packages have requirement for older version.

[root merlin Michael]# yum update
Loaded plugins: refresh-packagekit
Repository atrpms is listed more than once in the configuration
atrpms | 1.9 kB 00:00 google | 951 B 00:00 fedora | 2.8 kB 00:00 rpmfusion-free-updates | 2.7 kB 00:00 rpmfusion-nonfree-updates | 2.7 kB 00:00 rpmfusion-free | 2.7 kB 00:00 adobe-linux-i386 | 951 B 00:00 rpmfusion-nonfree | 2.7 kB 00:00 updates | 2.3 kB 00:00 Setting up Update Process Resolving Dependencies --> Running transaction check --> Processing Dependency: libavcodec.so.51 for package: k3b-extras-freeworld --> Processing Dependency: libavcodec.so.51 for package: xine-lib-extras-freeworld --> Processing Dependency: libavcodec.so.51 for package: gstreamer-ffmpeg --> Processing Dependency: libavdevice.so.52 for package: ffmpeg --> Processing Dependency: libavformat.so.52 for package: k3b-extras-freeworld --> Processing Dependency: libavformat.so.52 for package: gstreamer-ffmpeg --> Processing Dependency: libavformat.so.52 for package: ffmpeg --> Processing Dependency: libavutil.so.49 for package: ffmpeg --> Processing Dependency: libavutil.so.49 for package: xine-lib-extras-freeworld --> Processing Dependency: libavutil.so.49 for package: libavcodec52 --> Processing Dependency: libavutil.so.49 for package: gstreamer-ffmpeg --> Processing Dependency: libpostproc.so.51 for package: xine-lib-extras-freeworld --> Processing Dependency: libpostproc.so.51 for package: gstreamer-ffmpeg
--> Processing Dependency: libpostproc.so.51 for package: ffmpeg
--> Processing Dependency: libswscale.so.0 for package: libquicktime
--> Processing Dependency: libswscale.so.0 for package: ffmpeg
---> Package x264.i386 0:0.65-8_20081108.2245.fc10 set to be updated
---> Package faad2.i386 1:2.6.1-10.fc10 set to be updated
---> Package ffmpeg.i386 0:0.4.9-28_r15845.fc10 set to be updated
--> Running transaction check
---> Package libavutil49.i386 0:0.4.9-28_r15845.fc10 set to be updated
---> Package libpostproc51.i386 0:0.4.9-28_r15845.fc10 set to be updated
---> Package libswscale0.i386 0:0.4.9-28_r15845.fc10 set to be updated
--> Processing Dependency: libavcodec.so.51 for package: k3b-extras-freeworld --> Processing Dependency: libavcodec.so.51 for package: xine-lib-extras-freeworld
--> Processing Dependency: libavcodec.so.51 for package: gstreamer-ffmpeg
---> Package libavdevice52.i386 0:0.4.9-28_r15845.fc10 set to be updated
---> Package libavformat52.i386 0:0.4.9-28_r15845.fc10 set to be updated
--> Finished Dependency Resolution
k3b-extras-freeworld-1.0.5-4.fc10.i386 from installed has depsolving problems --> Missing Dependency: libavcodec.so.51 is needed by package k3b-extras-freeworld-1.0.5-4.fc10.i386 (installed)
gstreamer-ffmpeg-0.10.5-1.fc10.i386 from installed has depsolving problems
--> Missing Dependency: libavcodec.so.51 is needed by package gstreamer-ffmpeg-0.10.5-1.fc10.i386 (installed) xine-lib-extras-freeworld-1.1.16-1.fc10.i386 from installed has depsolving problems --> Missing Dependency: libavcodec.so.51 is needed by package xine-lib-extras-freeworld-1.1.16-1.fc10.i386 (installed) Error: Missing Dependency: libavcodec.so.51 is needed by package gstreamer-ffmpeg-0.10.5-1.fc10.i386(installed) Error: Missing Dependency: libavcodec.so.51 is needed by package xine-lib-extras-freeworld-1.1.16-1.fc10.i386 (installed) Error: Missing Dependency: libavcodec.so.51 is needed by package k3b-extras-freeworld-1.0.5-4.fc10.i386 (installed)
[root merlin Michael]#
--------------
But you don't understand silly computer.... I have that file...

[root merlin lib]# ls -l libavcode*
lrwxrwxrwx 1 root root 21 2009-01-15 12:05 libavcodec.so.51 -> libavcodec.so.51.71.0
-rwxr-xr-x 1 root root 3517336 2008-11-20 14:44 libavcodec.so.51.71.0
lrwxrwxrwx 1 root root 20 2009-01-15 22:05 libavcodec.so.52 -> libavcodec.so.52.3.0
-rwxr-xr-x 1 root root 5104808 2008-11-23 11:37 libavcodec.so.52.3.0
[root merlin lib]#
----------------------------------------
So what do I do now? .... besides go out and get catastrophically intoxicated, which still doesn't get my machine updated....

Michael
------------


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]